Onderwerp : toetsenbord probleem

Auteur : Amedee Van Gasse
E-mail : amedee op amedee.be
Datum : Za Feb 3 01:02:51 GMT 2007


Op vrijdag 02-02-2007 om 16:13 uur [tijdzone +0100], schreef
FD-Computers:
> Hallo,
> 
> Ik heb hier een pc die telkens waneer hij in kde komt geen toetsenbord 
> meer ontvangt.
> 
> Als je niet in X start, geen enkel probleem.
> 
> Bij het inloggen op kdm lukt het wel nog, van het moment dat kde gestart 
> is niets meer.
> 
> Vga drivers zijn correct ge´nstalleerd en muis werkt ook nog perfect.
> 
> Wat kan dit veroorzaken ?

Wat *kan* dit veroorzaken: bluetooth.
Ik heb dit voor met mijn bluetooth toetsenbord. Jouw beschrijving komt
exact overeen met wat ik ervaar, dus ik ga er van uit dat je ook een
bluetooth toppenbord hebt, ook al heb je dat niet expliciet vermeld. En
als dat niet zo is, gelieve dan wat meer info te geven. :)

Ik *moet* mijn bluetooth usb dongle opstarten als een legacy HID device
in plaats van als een HCI device. Gevolg is: wanneer de bluetooth in
legacy HID staat, kan ik niet synchroniseren met m'n smartphone (nokia
6680). En wanneer de bluetooth in HCI staat, heb ik wel connectie met
m'n gsm, maar dan heb ik geen toetsenbord (of muis).

Het gaat om een Logitech MX5000 en om bug 32415:
https://bugs.launchpad.net/ubuntu/+source/bluez-utils/+bug/32415
Laat je niet misleiden door de uitleg dat de bug zich alleen stelt bij
de PowerPC: het probleem stelt zich op alle architecturen, bij alle
bluetooth usb dongles met een broadcomm chipset.

Ik vind het trouwens een echte schande dat deze bug al bijna een jaar
open staat en er maar niets aan gedaan wordt. Dit is een echte
showstopper en voor mij de voornaamste reden dat ik over enkele maanden,
wanneer ik ooit nog eens tijd heb, ga uitkijken naar een andere distro
waar bluetooth wÚl normaal werkt (want upstream zou de bug naar verluid
al lang opgelost zijn...)

-- 
Amedee