Onderwerp : GRUB: kiezen versies kernel-modules bij booten

Auteur : Kristoff Bonne
E-mail : kristoff.bonne op skypro.be
Datum : Zo Dec 23 21:55:55 GMT 2007


Groeten aan allen die zijn en zullen zijn,



Ik zit hier met een nogal ambetant probleempje. Ik bezit aan de ene kant
een logitech quickcam chat (die onder linux herkend wordt als een
logitech messanger) en -aan de andere kant- ook een "Zolid Hi-speed DVD
Maker".


Die laatste wordt niet standaard door ubuntu herkent (is iets dat enkele
weken geleden verkocht werd in de aldi) maar intern is dat blijkbaar een
"Yakumo MovieMixer".
De driver voor de em28xx die standaard in Ubuntu 7.10 zit kent dit
toestel niet, maar men kan wel een experimente versie vinden via (o.a.)
de uitleg op deze pagina: http://mcentral.de/wiki/index.php/Em2880

Probleem is dat deze driver zich dus in de plaats van de standaard
em28xx-driver zet, waardoor mijn logitech webcam (de "gspca"-driver)
plots niet meer wil laden. Ik krijg allerlei foutmeldingen zoals dit:
"gspca: disagrees about version of symbol video_register_device").


Dus, ik vermoed dat de enige oplossing is om verschillende versies van
modules te hebben en die in apparte /lib/modules/... directories te
zetten, één voor als ik de logitech wil gebruiken, en één voor als ik
videos wil opnemen.

Dus, hoe configureer je GRUB dat je linux kunt booten met verschillende
plaatsen waar dat hij de modules gaat zoeken?
(ik weet dat de directories waar dat hij de modules gaat zoeken (in
/lib/modules/...) blijkbaar ergens gelinked zijn aan wat dat je krijgt
als je "uname -a" doet.



Iemand enig idee?


Cheerio! Kr. Bonne.