[Ubuntu-ni] Problema grave en dpkg

michael castellon sousuke.eo en gmail.com
Sab Mar 28 14:48:00 GMT 2009


prueba esto.
1._
$sudo apt-get check

2._
$sudo aptitude update
$sudo aptitude install "nombre_del_programa"

sino funciona proba leer los manuales, ya lo hice y no encontre nana
que tenga ver..

$man apt-get
$man aptitide

2009/3/27 Joel Davila <6336737 en gmail.com>:
> Al vecino le acaba de pasar algo asi, estaba instalando flashplayer y como
> se le pego el synaptic reinicio la maquina "a la windows" :S
>
> No puede instalar nada ahora, incluso le dije que probara a darle "dpkg
> --configure -a" y me dice que no le acepta el passwd del root.
>
> sera caso similar?
>
> 2009/3/27 Marcos Iván Miranda García <mimg2805 en gmail.com>
>>
>> Nada. Me da el mismo error.
>>
>> Parece ser un problema co el archivo /var/lib/dpkg/status: está corrupto o
>> tiene muchas descripciones o algo.
>>
>> Quizá...
>>
>> 2009/3/27 Igor Guerrero <igfgt1 en gmail.com>
>>>
>>> sudo dpkg --configure -a
>>>
>>> O
>>>
>>> sudo apt-get install -f
>>>
>>> On Mar 27, 2009 7:41 PM, "Marcos Iván Miranda García"
>>> <mimg2805 en gmail.com> wrote:
>>>
>>> Hola a toda la comunidad,
>>>
>>> Recientemente, update -manager y Synaptic me han dejado de funcionar. No
>>> puedo instalar actualizaciones.
>>>
>>> El update-manager me lanza esto:
>>>
>>> Ha ocurrido un problema imposible de corregir cuando se inicializaba la
>>> información de los paquetes.
>>>
>>> Por favor, informe de ésto como un fallo en el paquete «update-manager» e
>>> incluya el siguiente mensaje de error:
>>>
>>> 'E:Vaya, excedió el número de descripciones que este APT es capaz de
>>> manejar., E:Problem with MergeList /var/lib/dpkg/status, E:No se pudieron
>>> analizar o abrir las listas de paquetes o el archivo de estado.'
>>>
>>> El Synaptic me lanza esto:
>>>
>>> E: Vaya, excedió el número de descripciones que este APT es capaz de
>>> manejar.
>>> E: Problem with MergeList /var/lib/dpkg/status
>>> E: Las listas de paquetes o el archivo de estado no se pueden analizar
>>> sintácticamente o abrir.
>>> E: _cache->open() failed, please report.
>>>
>>> Y el apt-get update me lanza esto:
>>>
>>> Leyendo lista de paquetes... ¡Error!
>>> E: Vaya, excedió el número de descripciones que este APT es capaz de
>>> manejar.
>>> E: Problem with MergeList /var/lib/dpkg/status
>>> E: No se pudieron analizar o abrir las listas de paquetes o el archivo de
>>> estado.
>>>
>>> Todos coinciden en que el archivo /var/lib/dpkg/status excedió el máximo
>>> de descripciones posibles o algo así. No sé qué hacer.
>>>
>>> He intendado:
>>>
>>> sudo dpkg --clear-avail
>>> sudo rm /var/lib/apt/lists/* -vf
>>> sudo mv /var/lib/dpkg/status-old /var/lib/dpkg/status
>>>
>>> sin éxito.
>>>
>>> ¿Qué puedo hacer? Ya no puedo instalar, actualizar o remover nada. Espero
>>> su respuesta,
>>>
>>> Marcos Miranda
>>>
>>> --
>>> Ubuntu-ni mailing list
>>> Ubuntu-ni en lists.ubuntu.com
>>> Modify settings or unsubscribe at:
>>> https://lists.ubuntu.com/mailman/listinfo/ubuntu-ni
>>>
>>>
>>> --
>>> Ubuntu-ni mailing list
>>> Ubuntu-ni en lists.ubuntu.com
>>> Modify settings or unsubscribe at:
>>> https://lists.ubuntu.com/mailman/listinfo/ubuntu-ni
>>>
>>
>>
>> --
>> Ubuntu-ni mailing list
>> Ubuntu-ni en lists.ubuntu.com
>> Modify settings or unsubscribe at:
>> https://lists.ubuntu.com/mailman/listinfo/ubuntu-ni
>>
>
>
>
> --
> ----
> Joel Dávila (505)816-9911
> https://fedoraproject.org/wiki/User:Joe74
> http://teoten.wordpress.com/
> ------------
> "Is there something safer as /home/?
> I don't think so...
> Are you ok at C:\Documents and Settings\?"
> -------
>
> --
> Ubuntu-ni mailing list
> Ubuntu-ni en lists.ubuntu.com
> Modify settings or unsubscribe at:
> https://lists.ubuntu.com/mailman/listinfo/ubuntu-ni
>
>



Más información sobre la lista de distribución Ubuntu-ni