[DEVELOPERS] [Fwd: Launchpadlib support in Ubuntu Developer Tools]

James Westby jw+debian at jameswestby.net
Wed Jan 14 13:45:02 GMT 2009


-------- Forwarded Message --------
From: Jonathan Davies <jpds at ubuntu.com>
To: Ubuntu MOTU Developers <ubuntu-motu at lists.ubuntu.com>, Ubuntu Core
developers <ubuntu-devel at lists.ubuntu.com>
Subject: Launchpadlib support in Ubuntu Developer Tools
Date: Wed, 14 Jan 2009 14:39:07 +0100

Hey folks,

thekorn and I have been working on getting python-launchpadlib support
to the Ubuntu Developer Tools package.

So far, we've added support for the bug reporting; for example, sync
requests with the --lp flag will use the launchpadlib API to file the
bugs. But I hope to port more things across, as things get added to
the API.

All one needs is a LP token authenticated and have it written to
~/.lp_credentials.txt . I've written how one can go about doing this,
in the examples section of the manage-credentials manpage.

The support is available in the latest Jaunty packages (0.52), however
these should be installable on Intrepid.

Please report all bugs you find to the usual place at:

    https://bugs.launchpad.net/ubuntu/+source/ubuntu-dev-tools/

Cheers,
Jonathan




More information about the Ubuntu-news-team mailing list