Bug#602051: mozilla-devscripts: Please make xpi:Recommends generate versioned target applications
1o5g4r8o at gmail.com
Mon Nov 15 13:24:09 UTC 2010
On Sun, Nov 14, 2010 at 11:29 PM, Benjamin Drung <bdrung at ubuntu.com> wrote:
> Am Montag, den 01.11.2010, 03:02 +0100 schrieb Gabriele Giacone:
>> Could you please include min/max required application versions?
> We could set min and max version if only one package is listed in
> Recommends. For example
> Recommends: iceweasel (>= 3.6), iceweasel (<= 4.0~b2pre)
> But what should mozilla-devscripts do if alternatives like "iceweasel |
> icedove" are generated?
Recommends: iceweasel (>= 3.6), iceweasel (<= 4.0~b2pre), icedove (>=
3.1), icedove (<= 3.1.6)
Any existing extension which recommends both?
>> Something like
>> Recommends: iceweasel (>= 3.6)
> Setting the min version is doable, but all mozilla application have to
> follow one conversion rule for converting upstream versions to debian
> versions (e.g. 4.0b2pre -> 4.0~b2pre).
Yes, and adding even <=maxVersion if exists wouldn't be bad.
More information about the Ubuntu-mozillateam