[HELP] : dpkg-buildpackage: fallo: fakeroot debian/rules binary gave error exit status 2

Saša Bodiroža jazzva at gmail.com
Tue Jan 6 13:08:53 GMT 2009


Hello Kiki,

In case Alexander's suggestion doesn't work, try with this. I think
you should set MOZ_XPI_EMID to that specified in the install.rdf file.
I usually bumped into this problem when xpi.mk failed to parse ID from
install.rdf. So, replace the line

#MOZ_XPI_EMID := {xxxxxxx-xxxx-xxxx}

with

MOZ_XPI_EMID := {your-id}

where your-id is the ID found in the install.rdf in <em:id> tag. Be
sure to use the one for the extension, and not the one which is
related to compatible software (e.g. Firefox, Thunderbird, ...). Also,
don't forget to uncomment the line by removing the "#" character. If
this fails, try setting MOZ_XPI_FILE, by changing

#MOZ_XPI_FILE := yourextension.xpi

to

MOZ_XPI_FILE := purezilla.xpi

I hope this helps...

Unrelated to this problem, there are other things that should be
fixed. Fix XSBC-Original-Maintainer field in debian/control. Also, fix
Standards-Version and Depends fields by removing the "s" character
from the end.

-- 
Best regards,
Saša Bodiroža


More information about the Ubuntu-mozillateam mailing list