[Bug 1872586] [NEW] firefox won't display WEBGL web page in 20.04 ok in 19.10

Richard Thiebaud 1872586 at bugs.launchpad.net
Tue Apr 14 03:24:10 UTC 2020


Public bug reported:

When I open a website using WEBGL, firefox displays a message that the browser does not
support GL. The GL support is enabled in firefox. The command line displays:

libGL error: MESA-LOADER: failed to retrieve device information
libGL error: Version 4 or later of flush extension not found
libGL error: failed to load driver: i915
libGL error: MESA-LOADER: failed to retrieve device information

This happens in Ubuntu 20.04 beta. In Ubuntu 19.10 with the same browser and
browser settings, the website is displayed correctly. Chromium displays the
same page correctly both on 19.10 and 20.04.

Sample website: www.geocaching.com/play/map

ProblemType: Bug
DistroRelease: Ubuntu 20.04
Package: firefox 75.0+build3-0ubuntu1
ProcVersionSignature: Ubuntu 5.4.0-21.25-generic 5.4.27
Uname: Linux 5.4.0-21-generic x86_64
AddonCompatCheckDisabled: False
ApportVersion: 2.20.11-0ubuntu26
Architecture: amd64
AudioDevicesInUse:
 USER        PID ACCESS COMMAND
 /dev/snd/controlC0:  dick       1252 F.... pulseaudio
BuildID: 20200403170909
CasperMD5CheckResult: skip
Channel: Unavailable
CurrentDesktop: X-Cinnamon
Date: Mon Apr 13 23:20:24 2020
DefaultProfileExtensions: extensions.sqlite corrupt or missing
DefaultProfileIncompatibleExtensions: Unavailable (corrupt or non-existant compatibility.ini or extensions.sqlite)
DefaultProfileLocales: extensions.sqlite corrupt or missing
DefaultProfilePrefErrors: Unexpected character ',' before close parenthesis @ /usr/lib/firefox/omni.ja:greprefs.js:733
DefaultProfileThemes: extensions.sqlite corrupt or missing
ForcedLayersAccel: False
InstallationDate: Installed on 2020-03-04 (40 days ago)
InstallationMedia: Ubuntu 19.10 "Eoan Ermine" - Release amd64 (20191017)
IpRoute:
 default via 192.168.1.1 dev enp2s0 proto dhcp metric 100 
 169.254.0.0/16 dev enp2s0 scope link metric 1000 
 192.168.1.0/24 dev enp2s0 proto kernel scope link src 192.168.1.243 metric 100
ProcEnviron:
 TERM=xterm-256color
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
Profile0Extensions: extensions.sqlite corrupt or missing
Profile0IncompatibleExtensions: Unavailable (corrupt or non-existant compatibility.ini or extensions.sqlite)
Profile0Locales: extensions.sqlite corrupt or missing
Profile0PrefErrors: Unexpected character ',' before close parenthesis @ /usr/lib/firefox/omni.ja:greprefs.js:733
Profile0PrefSources: prefs.js
Profile0Themes: extensions.sqlite corrupt or missing
Profile2Extensions: extensions.sqlite corrupt or missing
Profile2IncompatibleExtensions: Unavailable (corrupt or non-existant compatibility.ini or extensions.sqlite)
Profile2Locales: extensions.sqlite corrupt or missing
Profile2PrefErrors: Unexpected character ',' before close parenthesis @ /usr/lib/firefox/omni.ja:greprefs.js:733
Profile2PrefSources: prefs.js
Profile2Themes: extensions.sqlite corrupt or missing
Profiles:
 Profile1 (Default) - LastVersion=None/None (Out of date)
 Profile0 - LastVersion=75.0/20200403170909 (In use)
 Profile2 - LastVersion=75.0/20200403170909
RunningIncompatibleAddons: False
SourcePackage: firefox
UpgradeStatus: Upgraded to focal on 2020-04-13 (0 days ago)
dmi.bios.date: 05/10/2019
dmi.bios.vendor: Dell Inc.
dmi.bios.version: 2.10.0
dmi.board.name: 0C0JMC
dmi.board.vendor: Dell Inc.
dmi.board.version: A00
dmi.chassis.type: 9
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvr2.10.0:bd05/10/2019:svnDellInc.:pnInspiron15-3567:pvr:rvnDellInc.:rn0C0JMC:rvrA00:cvnDellInc.:ct9:cvr:
dmi.product.family: Inspiron
dmi.product.name: Inspiron 15-3567
dmi.product.sku: 078B
dmi.sys.vendor: Dell Inc.

** Affects: firefox (Ubuntu)
     Importance: Undecided
         Status: New


** Tags: amd64 apport-bug focal

-- 
You received this bug notification because you are a member of Mozilla
Bugs, which is subscribed to firefox in Ubuntu.
https://bugs.launchpad.net/bugs/1872586

Title:
  firefox won't display WEBGL web page in 20.04 ok in 19.10

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/firefox/+bug/1872586/+subscriptions



More information about the Ubuntu-mozillateam-bugs mailing list