[Bug 1711337] Re: Firefox crashes at start on armv7L after 55.0.1 update

James Donald 1711337 at bugs.launchpad.net
Mon Mar 19 01:27:28 UTC 2018


Awesome, thanks for confirming Arch still works and posting the
screenshot.

> Also anyone tried to run the binary from bionic, which should be built
with gcc-7 as well?

Yes, Lars and I both tried this. It's rather buried in discussion above
but search for the part where I mention "ignore the dependency" in order
to test the gcc 7 Bionic build on a Xenial system.

> --enable-rust-simd caught eye, what is this all about?

There are Rust bindings for Skia, but the part where it crashes doesn't
use Rust. From your screenshot I think these are likely the key missing
flags: -march=armv7-a -mfloat-abi=hard -mfpu=vfpv3-d16

In the conversation above, those are exactly the flags we suspected from
comparing the Chromium build. Looks like we don't actually need clang,
and we don't need -mthumb

Well, there's still the other startup crash specific to Ubuntu 16.04
packages. Given we don't hit it on the Bionic nor Trusty builds, that
problem is likely specific to gcc 5.4

Now we just need someone with access to change the default build
settings on Launchpad.

-- 
You received this bug notification because you are a member of Mozilla
Bugs, which is subscribed to the bug report.
https://bugs.launchpad.net/bugs/1711337

Title:
  Firefox crashes at start on armv7L after 55.0.1 update

To manage notifications about this bug go to:
https://bugs.launchpad.net/firefox/+bug/1711337/+subscriptions



More information about the Ubuntu-mozillateam-bugs mailing list