[Bug 1051559] Re: Build Firefox with GStreamer 1.0 support

Mozaic vulcain at gmx.com
Sat Apr 5 10:34:55 UTC 2014


@ j^ (j) : In 2011, there a fork in FFmpeg, some developper go away and
create Libav.

Ubuntu/Debian maintener choose  LibAv: http://forums.debian.net/viewtopic.php?f=6&t=73558 
https://launchpad.net/libav/+packages
https://launchpad.net/libav
and there are an error message when you launch ffmpeg in terminal:
" *** THIS PROGRAM IS DEPRECATED ***
This program is only provided for compatibility and will be removed in a future release. Please use avconv instead. "

Gstreamer could use the both now: http://gstreamer.freedesktop.org/releases/gst-libav/0.11.90.html
In  14.04 gstreamer1.0-libav  make the job of gstreamer0.10-ffmpeg: 
https://launchpad.net/ubuntu/trusty/i386/gstreamer0.10-ffmpeg
https://launchpad.net/ubuntu/+source/gst-libav1.0

FFmpeg could come back to Debian:
http://www.phoronix.com/scan.php?page=news_item&px=MTYxNjA

The problem is that now with Firefox 28, we could not see H264 in Ubuntu 14.04, but we could do it in 12.04
If you want to test: http://www.quirksmode.org/html5/tests/video.html
I try use Aurora (Firefox 30 alpha) on Ubuntu 14.04, no H264 video. I check about:config and media.gstreamer.enabled is true
The same video on Ubuntu 12.04 work fine with Aurora

As i understand, when Firefox have <video> with H264, it use gstreamer who use gstreamer*-ffmpeg who use gstreamer-plugins-bad and gstreamer-plugins-ugly to read H264.
But with LibAv, how does it's work ?? I forget a plugin ?? Firefox use gtsreamer who use gst-libav1.0 and after i don't know.
I  find one bug with LibAV in Firefox bugzilla, it's very short: https://bugzilla.mozilla.org/show_bug.cgi?id=801521

** Bug watch added: Mozilla Bugzilla #801521
   https://bugzilla.mozilla.org/show_bug.cgi?id=801521

-- 
You received this bug notification because you are a member of Mozilla
Bugs, which is subscribed to firefox in Ubuntu.
https://bugs.launchpad.net/bugs/1051559

Title:
  Build Firefox with GStreamer 1.0 support

To manage notifications about this bug go to:
https://bugs.launchpad.net/firefox/+bug/1051559/+subscriptions




More information about the Ubuntu-mozillateam-bugs mailing list