[Bug 602877] Re: Position is not being updated when atk_text_set_caret_offset is used

Attila Hammer hammera at pickup.hu
Tue Oct 18 05:03:33 UTC 2011


Hy Micah,

Sorry if my comment parts are perhaps little offtopic this problem related:
This is a difficult question, because newest Firefox and Thunderbird 
releases are containing for example following important bug for A11y 
related:
https://bugzilla.mozilla.org/show_bug.cgi?id=619002
A screen reader user important to hear the deleted characters for 
example if writing a new e-mail or writing any data with a webpage, for 
example if writing comments, or if online doing financial operations 
with a net bank.
I using Ubuntu releases with screen reader support only, and Using 
basicaly Firefox 3.6 release my Lucid system.
Since Firefox 4.0 release this bug is present, the developers working 
this bug fixing, now I think this bug fix target milestone is Firefox 10.
Lucid release default containing Orca screen reader 2.30 version, with 
not support I think default good with Thunderbird 3.1.x releases, 
default slow the list navigation with large mail folders.
This problem are wonderful fixed with Orca 3.0 version, but this version 
are default GNOME 3.0 compatible, I need doing a patched version of 3.0 
package my Lucid system with not containing gsettings related changes.

Orca 3.0 release wonderful usable for example Thunderbird 3.1.15 
version, but newest Thunderbird 7.0 release containing too this 
backspace echoing related issue.
Newest Thunderbird 7.0 and Orca 3.2 release are have performance issues 
for example with Oneiric, with I not found yet a workaround to resolve:
https://bugzilla.gnome.org/show_bug.cgi?id=660218

I no and agree, Mozilla support modell is changed, fastest releasing the 
Mozilla products releases, so Ubuntu Mozilla team work is not easy to 
always follow up changes. More sighted users using worldwide Ubuntu 
releases, and would like upgrade perhaps the newest releases. But what 
will be happening if an upgrade breaks A11y support for a Mozilla 
product with visual impaired users worldwide?
Possible doing future an easy possibility to easy install prewious 
Mozilla products version?
For example, if I install direct firefox-3.6 package version, will be 
upgrading now automaticaly with newest upstream main releases with 
rolling if main stable version are changing, because main firefox 
package version is changing. For exampe, if you are uploading Lucid 
branch the Firefox 7.0 package version, will be upgrading now my Firefox 
version from 3.6 to 7.0, and I will be experiencing Orca not spokening 
for example text entry fields deleted characters and very surprised if I 
not known this A11y related bug.
Now not have possibility to I determine for example I would like only 
Firefox 3.6 related security updates, or I don't known the good 
technique. :-):-)
Not good possibility to visual impaired users holding Firefox and 
Thunderbird releases, because this operation result not awailable the 
security updates for a Firefox and Thunderbird release entire.
Lot of visual impaired users using Ubuntu or Ubuntu based accessibility 
support completed derivative distribution.
An international distribution with affecting this upgrade is Vinux:
http://vinuxproject.org/

Attila

-- 
You received this bug notification because you are a member of Mozilla
Bugs, which is subscribed to firefox in Ubuntu.
https://bugs.launchpad.net/bugs/602877

Title:
  Position is not being updated when atk_text_set_caret_offset is used

To manage notifications about this bug go to:
https://bugs.launchpad.net/firefox/+bug/602877/+subscriptions




More information about the Ubuntu-mozillateam-bugs mailing list