[Bug 740815] Re: [FFe] Updates to enable us to drop xulrunner from main

Martin Pitt martin.pitt at ubuntu.com
Wed Mar 23 18:24:24 UTC 2011


Split-out for python-gtkspell:

python-gtkspell (2.25.3-7ubuntu2) natty; urgency=low

  * Split out python-gtkspell from gnome-python-extras. It is the only package
    that we need in main, which allows us to drop xulrunner into universe.
    (LP: #740815)
  * debian/control: Update Vcs-Bzr: for new branch name.

 -- Martin Pitt <martin.pitt at ubuntu.com>  Wed, 23 Mar 2011 19:05:59
+0100

Note that I should actually remove the package from gnome-python-extras
now, but it doesn't build:

libtool: compile:  g++ -DHAVE_CONFIG_H -I. -I/home/martin/ubuntu/build-area/gnome-python-extras-2.25.3/./gtkmozembed -I.. -I/usr/include/python2.6 -pthread -I/usr/include/glib-2.0 -I/usr/lib/x86_64-linux-gnu/glib-2.0/include -I/usr/include/atk-1.0 -I/usr/include/gio-unix-2.0/ -I/usr/include/freetype2 -I/usr/include/libpng12 -I/usr/include/libdrm -I/usr/include/pygtk-2.0 -I/usr/include/gtk-2.0 -I/usr/lib/gtk-2.0/include -I/usr/include/cairo -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/pango-1.0 -I/usr/include/pixman-1 -pthread -DXPCOM_GLUE -fshort-wchar -I/usr/include/atk-1.0 -I/usr/include/gio-unix-2.0/ -I/usr/include/glib-2.0 -I/usr/lib/x86_64-linux-gnu/glib-2.0/include -I/usr/include/freetype2 -I/usr/include/libpng12 -I/usr/include/libdrm -I/usr/include/xulrunner-2.0 -I/usr/include/xulrunner-2.0/nspr -I/usr/include/gtk-2.0 -I/usr/lib/gtk-2.0/include -I/usr/include/cairo -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/pango-1.0 -I/usr/include/pixman-1 -g -O2 -g -O2 -c /home/martin/ubuntu/build-area/gnome-python-extras-2.25.3/./gtkmozembed/gtkmozembedmodule.cpp  -fPIC -DPIC -o .libs/gtkmozembedmodule.o
/home/martin/ubuntu/build-area/gnome-python-extras-2.25.3/./gtkmozembed/gtkmozembedmodule.cpp:10:32: fatal error: gtkmozembed_glue.cpp: Datei oder Verzeichnis nicht gefunden

According to the previous build log against xulrunner-2.0b10 this came
from /usr/include/xulrunner-2.0b10/gtkmozembed_glue.cpp, but our current
xulrunner-dev doesn't ship that file any more. Packaging bug?

-- 
You received this bug notification because you are a member of Mozilla
Bugs, which is subscribed to Mozilla.
https://bugs.launchpad.net/bugs/740815

Title:
  [FFe] Updates to enable us to drop xulrunner from main




More information about the Ubuntu-mozillateam-bugs mailing list