[Bug 294187] Re: Firefox Locales should install locale specific search plugins

Launchpad Bug Tracker 294187 at bugs.launchpad.net
Tue Jun 21 22:09:15 UTC 2011


This bug was fixed in the package firefox - 5.0+build1+nobinonly-
0ubuntu0.11.04.1

---------------
firefox (5.0+build1+nobinonly-0ubuntu0.11.04.1) natty-security; urgency=low

  * New upstream release from the stable channel (FIREFOX_5_0_BUILD1)
    - see LP: #798484 for USN information

  * Update globalmenu-extension to 1.0.6
  * Switch to mozilla-beta
    - update debian/mozclient/firefox.conf
  * Drop the ability to build with an external xulrunner, and all the packaging
    complexity which went with it
    - update debian/apport/firefox.in
    - update debian/firefox.install.in
    - update debian/firefox.lintian-overrides.in
    - update debian/firefox.sh.in
    - update debian/mozconfig.in
    - update debian/rules
  * Build language packs directly from the firefox source
    + Fixes LP: #294187 - Firefox Locales should install locale specific
      search plugins
    + Rip out the bits to create a en-US.xpi
      - update debian/rules
      - remove debian/translation-support/install.rdf.in
    + Include compare-locales FIREFOX_5_0b1_BUILD1 from
      http://hg.mozilla.org/build/compare-locales. It's needed for merging
      en-US strings with incomplete locales
    + Pull l10n data in to tarball from bzr
      - update debian/mozclient/firefox.conf
    + Configure build for creating language packs by configuring with
      "--with-l10n-base="
      - update debian/mozconfig.in
    + Store the list of locales to ship, and provide a way of automatically
      generating that list and the control file entries from the upstream
      source. Also provide a way to blacklist languages. We map languages
      to package names using langpack-o-matic (and also get descriptions
      from there too)
      - update debian/rules
      - add debian/locales-supported
      - add debian/control.langpacks
      - update debian/control
      - add debian/locale-blacklist
      - add debian/refresh-supported-locales.pl
    + Add common-build-indep hook to build the translation xpi's
      - update debian/rules
    + Add common-binary-post-install-indep to install the xpi's and
      searchplugins in to the correct debian packages
      - update debian/rules
      - add debian/get-xpi-id.py
    + When rebuilding debian/control in the clean target, fail the build
      if the control file was out-of-date. This ensures that we don't
      accidentally drop language packs, and forces me to maintain an
      up-to-date control file in bzr
      - update debian/rules
    + Apply vendor patches to localized searchplugins too
      - update debian/patches/ubuntu-codes-amazon.patch
      - add debian/patches/ubuntu-codes-baidu.patch
      - update debian/patches/ubuntu-codes-google.patch
  * Ditch all the version-number based branding selection. Do this all
    purely on the channel name now
    - remove debian/firefox-beta.desktop.in
    - remove debian/firefox-nightly.desktop.in
    - remove debian/firefox-unofficial.desktop.in
    - rename debian/firefox-final.desktop.in => debian/firefox.desktop.in
    - update debian/firefox.desktop.in
    - update debian/rules
    - update debian/firefox.sh.in
  * Drop the DEB_ENABLE_IPC option, now that IPC is mandatory
    - update debian/rules
    - update debian/apport/firefox.in
    - update debian/firefox.install.in
    - update debian/mozconfig.in
  * Add some missing options to the manpage
    - update debian/firefox.1.in
  * Ensure we set LD_LIBRARY_PATH before running "firefox -h"
    - update debian/firefox.sh.in
  * Drop patches merged upstream:
    - 64-bit-be-fix.patch
  * Refresh patches:
    - mozilla-kde.patch
  * Ship channel-prefs.js. We used to ship this in Firefox 3.6, and it's
    required by Test Pilot now
    - update debian/firefox.install.in
  * Backport patch from mozilla-central to fix powerpc build failure
    - add debian/patches/powerpc-build-fix.patch
    - update debian/patches/series
  * Support storing language descriptions in locales.unavailable. This
    will be useful for translations which disappear temporarily
    - update debian/rules
    - update debian/refresh-supported-locales.pl
  * Add languages that are currently dropped in FF5 (compared with FF4) to
    locales.unavailable. Having transitional packages now will make
    transitioning easier later on if they come back
    - update debian/locales.unavailable
  * Refresh debian/control to pick up transitional packages
  * Don't bundle our vendor preferences in the omni.jar. This needs a distro
    patch and it turns out that Firefox does still read prefs from
    $LIBDIR/defaults/pref, so just install it there instead
    - update debian/rules
    - update debian/firefox.install.in
    - remove debian/patches/install-vendor-prefs.patch
    - update debian/patches/series
  * Add a global pref file again (/etc/firefox/syspref.js) and add the
    necessary preinst/postinst magic to move the old file there if it
    was previously customized
    - add debian/syspref.js
    - update debian/firefox.install.in
    - update debian/firefox.links.in
    - update debian/firefox.postinst.in
    - update debian/firefox.preinst.in
  * Ensure "Depends: ${misc:Depends}" is added to all transitional
    language packs
    - update debian/control.langpacks.unavail
    - refresh debian/control
  * Ship testpilot on aurora too
    - update debian/firefox.install.in
  * Set the right Vcs-Bzr URL
    - update debian/control.in
    - refresh debian/control
  * Update list of language packs to include new ones added upstream
    - refresh debian/locales.shipped and debian/locals.unavailable
    - refresh debian/control
 -- Chris Coulson <chris.coulson at canonical.com>   Fri, 17 Jun 2011 03:27:24 -0500

** Changed in: firefox (Ubuntu Natty)
       Status: Won't Fix => Fix Released

-- 
You received this bug notification because you are a member of Mozilla
Bugs, which is subscribed to firefox in Ubuntu.
https://bugs.launchpad.net/bugs/294187

Title:
  Firefox Locales should install locale specific search plugins

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu-translations/+bug/294187/+subscriptions




More information about the Ubuntu-mozillateam-bugs mailing list