[Bug 630643] Re: package firefox 3.6.8 build1 nobinonly-0ubuntu0.10.04.1 failed to install/upgrade: subprocess installed post-installation script returned error exit status 2

Launchpad Bug Tracker 630643 at bugs.launchpad.net
Fri Feb 25 14:00:11 UTC 2011


This bug was fixed in the package firefox - 4.0~b12+build1+nobinonly-
0ubuntu2

---------------
firefox (4.0~b12+build1+nobinonly-0ubuntu2) natty; urgency=low

  * Fix some typos in the manpage
    - update debian/firefox.1.in
  * Fix up the mess left by Ubuntuzilla rather than leaving our official
    package in a broken and inconsistent state, which ends up with users
    reporting bugs to Launchpad and giving us a bad reputation. If
    /usr/bin/firefox has been diverted and there is no /usr/bin/firefox
    provided on the system, just do the job of whatever package it was that
    broke the users install and remove the diversion for them. This should
    hopefully stop the frequently reported bugs we get from Ubuntuzilla users
    about /usr/bin/firefox being missing
    - update debian/firefox.postinst.in
    - Fixes LP: #512937, LP: #529136, LP: #552919, LP: #572733, LP: #574111,
      LP: #599978, LP: #600271, LP: #610522, LP: #610756, LP: #610907,
      LP: #612162, LP: #620400, LP: #623980, LP: #625014, LP: #630643,
      LP: #635166, LP: #638342, LP: #641838, LP: #658828, LP: #668809,
      LP: #672282, LP: #676239, LP: #707704, LP: #724090
  * Don't allow users to report bugs with apport-bug when /usr/bin/firefox
    has been diverted
    - update debian/firefox.py.in
  * Don't build with --disable-elfhack on armel. It's been fixed now
    - update debian/rules
 -- Chris Coulson <chris.coulson at canonical.com>   Fri, 25 Feb 2011 13:54:59 +0000

** Changed in: firefox (Ubuntu)
       Status: Invalid => Fix Released

-- 
You received this bug notification because you are a member of Mozilla
Bugs, which is subscribed to firefox in ubuntu.
https://bugs.launchpad.net/bugs/630643

Title:
  package firefox 3.6.8 build1 nobinonly-0ubuntu0.10.04.1 failed to
  install/upgrade: subprocess installed post-installation script
  returned error exit status 2




More information about the Ubuntu-mozillateam-bugs mailing list