[Bug 602672] Re: Thunderbird doesn't start after upgrade

Paul Gevers 602672 at bugs.launchpad.net
Sun Sep 12 11:59:27 UTC 2010

Hmm, I had the same problem today, again after an update.

I think it relevant that thunderbird is running during the upgrade.
After the upgrade I found that thunderbird was not responding as it
should (links weren't followed), soI killed thunderbird (via atl-f4),
and started thunderbird, which left me with a very small unuseful
window, which I closed again. I then check running thunderbird process
and found 3 long running thunderbird processes (some with a strange time
of 0:00, see below). After I killed those and again started thunderbird,
everything was fine.

I therefor think that in the installation script some intelligence needs
to be incorporated that checks on running processes and deals with them
appropriately. I have no idea what appropriately is thou.

paul at stromboli ~ $ ps aux |grep thunderbird
paul      1529  0.0  0.0   1832   488 ?        S    Sep11   0:00 /bin/sh /usr/lib/thunderbird-3.0.6/thunderbird
paul      1536  0.0  0.0   1832   488 ?        S    Sep11   0:00 /bin/sh /usr/lib/thunderbird-3.0.6/run-mozilla.sh /usr/lib/thunderbird-3.0.6/thunderbird-bin
paul      1544  1.4  5.9 257116 60152 ?        Sl   Sep11  15:33 /usr/lib/thunderbird-3.0.6/thunderbird-bin
paul      4113  0.0  0.0   3328   896 pts/1    S+   13:45   0:00 grep --color=auto thunderbird

Thunderbird doesn't start after upgrade
You received this bug notification because you are a member of Mozilla
Bugs, which is subscribed to thunderbird in ubuntu.

More information about the Ubuntu-mozillateam-bugs mailing list