[Bug 520772] [NEW] JTA Applet lost focus with TAB key event when JTA is run as Applet

focusbug wilsng at yahoo.com
Fri Feb 12 02:09:06 UTC 2010


Public bug reported:

Binary package hint: ubufox

Hi,

I am running into some weird focus issue with JTA Applet (actually any
applet with only 1 component in it, but let's just use the JTA applet
for testing/debugging purposes) if I launch the JTA as an embedded
applet.  When I type in the JTA telnet window, other keys works fine.
But, when I press the Tab key, the browser holding this applet seems to
steal the focus and transfer it to the next focusable component on the
browser frame.  Repeated TAB keypress does not return the focus back to
the JTA applet.

In comparison, on other OSes (Windows, Linux, Mac), when I press the Tab
key, the tab key event is reflected on my applet, but the focus remains
inside the applet window.  Ubuntu's behavior seems to differ from the
others.

I have changed following settings in the jta.conf file:

Applet.detach			=	false
Applet.detach.fullscreen	=	false
Applet.detach.immediately	=	false
Applet.detach.menuBar		=	false

If I run the JTA as an application, the TAB works fine.  But, I am
reporting this bug as a general bug with how Ubuntu handles the Tab key
event with applet.

As a different example, I wrote a simple applet containing only a Text
Area...in Ubuntu, when I type the Tab key in the text area, the focus is
lose.  When I run the same applet in Windows and type the same thing,
the focus remains in the TextArea and I can continue typing.

** Affects: ubufox (Ubuntu)
     Importance: Undecided
         Status: New

-- 
JTA Applet lost focus with TAB key event when JTA is run as Applet
https://bugs.launchpad.net/bugs/520772
You received this bug notification because you are a member of Mozilla
Bugs, which is subscribed to ubufox in ubuntu.




More information about the Ubuntu-mozillateam-bugs mailing list