[Bug 365392] Re: Cannot install or remove flashplugin

Ronny Ager-Wick ronny at ager-wick.com
Fri Oct 30 12:21:07 UTC 2009


I got a similar problem when upgrading a computer from kubutu hardy 8.04 to karmic 9.10 using adept.
During the upgrade it said the flashplugin-non-free package failed in some way. 
Now, it wont' install, configure or uninstall:

$ sudo apt-get install flashplugin-nonfree
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies.
  flashplugin-nonfree: Depends: flashplugin-installer but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

$ sudo apt-get install flashplugin-installer
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages were automatically installed and are no longer required:
(removed for clarity)
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
  flashplugin-nonfree
Suggested packages:
  ttf-xfree86-nonfree xfs
The following NEW packages will be installed
  flashplugin-installer
The following packages will be upgraded:
  flashplugin-nonfree
1 upgraded, 1 newly installed, 0 to remove and 2 not upgraded.
1 not fully installed or removed.
Need to get 0B/21.4kB of archives.
After this operation, 61.4kB of additional disk space will be used.
Do you want to continue [Y/n]? y
Preconfiguring packages ...
dpkg: error processing flashplugin-nonfree (--remove):
 Package is in a very bad inconsistent state - you should
 reinstall it before attempting a removal.
Errors were encountered while processing:
 flashplugin-nonfree
E: Sub-process /usr/bin/dpkg returned an error code (1)

$ sudo dpkg-reconfigure flashplugin-nonfree
/usr/sbin/dpkg-reconfigure: flashplugin-nonfree is broken or not fully installed.

$ sudo dpkg -r --force-all flashplugin-nonfree
dpkg: warning: overriding problem because --force enabled:
 Package is in a very bad inconsistent state - you should
 reinstall it before attempting a removal.
(Reading database ... 250232 files and directories currently installed.)
Removing flashplugin-nonfree ...
update-alternatives: error: no alternatives for iceape-flashplugin.
update-alternatives: error: no alternatives for iceape-flashplugin.
dpkg: error processing flashplugin-nonfree (--remove):
 subprocess installed pre-removal script returned error exit status 2
postinst called with argument `abort-remove'
dpkg: error while cleaning up:
 subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
 flashplugin-nonfree

OK, try to download and install:
$ wget http://no.archive.ubuntu.com/ubuntu/pool/multiverse/f/flashplugin-nonfree/flashplugin-nonfree_10.0.32.18ubuntu1_i386.deb
--2009-10-30 12:16:14--  http://no.archive.ubuntu.com/ubuntu/pool/multiverse/f/flashplugin-nonfree/flashplugin-nonfree_10.0.32.18ubuntu1_i386.deb
Resolving no.archive.ubuntu.com... 129.241.93.37, 2001:700:300:1800::b
Connecting to no.archive.ubuntu.com|129.241.93.37|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 1766 (1.7K) [application/x-debian-package]
Saving to: `flashplugin-nonfree_10.0.32.18ubuntu1_i386.deb'

100%[====================================================================================================>]
1,766       --.-K/s   in 0s

2009-10-30 12:16:15 (50.1 MB/s) - `flashplugin-
nonfree_10.0.32.18ubuntu1_i386.deb' saved [1766/1766]

$ sudo dpkg -i --force-all flashplugin-nonfree_10.0.32.18ubuntu1_i386.deb
(Reading database ... 250233 files and directories currently installed.)
Preparing to replace flashplugin-nonfree 9.0.246.0ubuntu1 (using flashplugin-nonfree_10.0.32.18ubuntu1_i386.deb) ...
update-alternatives: error: no alternatives for iceape-flashplugin.
update-alternatives: error: no alternatives for iceape-flashplugin.
dpkg: warning: old pre-removal script returned error exit status 2
dpkg - trying script from the new package instead ...
dpkg: error processing flashplugin-nonfree_10.0.32.18ubuntu1_i386.deb (--install):
 there is no script in the new version of the package - giving up
postinst called with argument `abort-upgrade'
dpkg: error while cleaning up:
 subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
 flashplugin-nonfree_10.0.32.18ubuntu1_i386.deb

NO LUCK!
Can't install, can't uninstall, can't reconfigure...

-- 
Cannot install or remove flashplugin
https://bugs.launchpad.net/bugs/365392
You received this bug notification because you are a member of Mozilla
Bugs, which is subscribed to flashplugin-nonfree in ubuntu.




More information about the Ubuntu-mozillateam-bugs mailing list