[Bug 338607] [NEW] dpkg: error processing /var/cache/apt/archives/xulrunner-1.9_1.9.0.7+nobinonly-0ubuntu1_amd64.deb (--unpack)

Savvas Radevic vicedar at gmail.com
Fri Mar 6 08:00:03 UTC 2009


Public bug reported:

Binary package hint: xulrunner-1.9

ubuntu jaunty alpha (updated)

$ apt-cache policy xulrunner-1.9
xulrunner-1.9:
  Installed: (none)
  Candidate: 1.9.0.7+nobinonly-0ubuntu1
  Version table:
     1.9.0.7+nobinonly-0ubuntu1 0
        500 http://archive.ubuntu.com jaunty/main Packages


Unpacking replacement xulrunner-1.9 ...
dpkg-deb: subprocess paste killed by signal (Broken pipe)
dpkg: error processing /var/cache/apt/archives/xulrunner-1.9_1.9.0.7+nobinonly-0ubuntu1_amd64.deb (--unpack):
 short read in buffer_copy (backend dpkg-deb during `./usr/lib/xulrunner-1.9.0.7/libxul.so')

$ sudo aptitude -f install
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Reading extended state information      
Initializing package states... Done
The following packages will be upgraded:
  xulrunner-1.9 
The following partially installed packages will be configured:
  firefox-3.0-gnome-support firefox-gnome-support xulrunner-1.9-gnome-support 
1 packages upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 0B/8714kB of archives. After unpacking 16.4kB will be used.
Do you want to continue? [Y/n/?] y
(Reading database ... 169112 files and directories currently installed.)
Preparing to replace xulrunner-1.9 1.9.0.6+nobinonly-0ubuntu1.1 (using .../xulrunner-1.9_1.9.0.7+nobinonly-0ubuntu1_amd64.deb) ...
Unpacking replacement xulrunner-1.9 ...
dpkg-deb: subprocess paste killed by signal (Broken pipe)
dpkg: error processing /var/cache/apt/archives/xulrunner-1.9_1.9.0.7+nobinonly-0ubuntu1_amd64.deb (--unpack):
 short read in buffer_copy (backend dpkg-deb during `./usr/lib/xulrunner-1.9.0.7/libxul.so')
Processing triggers for libc6 ...
ldconfig deferred processing now taking place
Errors were encountered while processing:
 /var/cache/apt/archives/xulrunner-1.9_1.9.0.7+nobinonly-0ubuntu1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
A package failed to install.  Trying to recover:
dpkg: dependency problems prevent configuration of xulrunner-1.9-gnome-support:
 xulrunner-1.9-gnome-support depends on xulrunner-1.9 (= 1.9.0.7+nobinonly-0ubuntu1); however:
  Version of xulrunner-1.9 on system is 1.9.0.6+nobinonly-0ubuntu1.1.
dpkg: error processing xulrunner-1.9-gnome-support (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of firefox-3.0-gnome-support:
 firefox-3.0-gnome-support depends on xulrunner-1.9-gnome-support (>= 1.9~b4~); however:
  Package xulrunner-1.9-gnome-support is not configured yet.
dpkg: error processing firefox-3.0-gnome-support (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of firefox-gnome-support:
 firefox-gnome-support depends on firefox-3.0-gnome-support; however:
  Package firefox-3.0-gnome-support is not configured yet.
dpkg: error processing firefox-gnome-support (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 xulrunner-1.9-gnome-support
 firefox-3.0-gnome-support
 firefox-gnome-support
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Reading extended state information       
Initializing package states... Done

** Affects: xulrunner-1.9 (Ubuntu)
     Importance: Undecided
         Status: New

-- 
dpkg: error processing /var/cache/apt/archives/xulrunner-1.9_1.9.0.7+nobinonly-0ubuntu1_amd64.deb (--unpack)
https://bugs.launchpad.net/bugs/338607
You received this bug notification because you are a member of Mozilla
Bugs, which is subscribed to xulrunner-1.9 in ubuntu.




More information about the Ubuntu-mozillateam-bugs mailing list