[Bug 220964] Re: mozilla-js CFLAGS are unusable

Michel Briand michelbriand at free.fr
Sat Feb 21 08:29:25 UTC 2009


Comment:

I didn't find the equivalent of Debian libmozjs-dev in Ubuntu. Since I
do not need full xulrunner sources but only SpiderMonkey.

Furthermore full xulrunner CFLAGS provided by pkg-config have 2
drawbacks that makes my build to fail :

- include subdir stable and unstable (confusing)
- include an embedded expat.h (serious)

---
$ diff /usr/include/xulrunner-1.9/unstable/expat.h /usr/include/expat.h 
986c986,987
<   XML_FEATURE_NS
---
>   XML_FEATURE_NS,
>   XML_FEATURE_LARGE_SIZE
1007,1012c1008
< #define XML_MICRO_VERSION 0
< 
< /* BEGIN MOZILLA CHANGE (Report opening tag of mismatched closing tag) */
< XMLPARSEAPI(const XML_Char*)
< MOZ_XML_GetMismatchedTag(XML_Parser parser);
< /* END MOZILLA CHANGE */
---
> #define XML_MICRO_VERSION 1
---

So to build FreeWRL package, I'm using libmozjs-dev (1.9.0.x) from
Debian stable.

And I install libmozjs1d (1.9.0.x) from Debian too, for runtime.

In configure.ac, thanks to Ian, we have :

AC_MSG_NOTICE([Determining Javascript engine to build against])
found_JAVASCRIPT_ENGINE=no
case "$os_type" in
     mac)
        AC_MY_CHECK_MODULE(JAVASCRIPT_ENGINE,spidermonkey,1.7.0)
        ;;
     *)
        AC_MY_CHECK_MODULE(JAVASCRIPT_ENGINE,mozilla-js,1.9)
        AC_MY_CHECK_MODULE(JAVASCRIPT_ENGINE,xulrunner-js,1.8)
        AC_MY_CHECK_MODULE(JAVASCRIPT_ENGINE,seamonkey-js)
        AC_MY_CHECK_MODULE(JAVASCRIPT_ENGINE,firefox-js)
        AC_MY_CHECK_MODULE(JAVASCRIPT_ENGINE,firefox2-js)
        ;;
esac

$ pkg-config --cflags mozilla-js
-DXP_UNIX -DJS_THREADSAFE -I/usr/include/mozjs -I/usr/include/nspr  

Cheers,
Michel

-- 
mozilla-js CFLAGS are unusable
https://bugs.launchpad.net/bugs/220964
You received this bug notification because you are a member of Mozilla
Bugs, which is subscribed to xulrunner-1.9 in ubuntu.




More information about the Ubuntu-mozillateam-bugs mailing list