[Bug 273905] [NEW] libmozjs-dev provides xulrunner-js.pc which is incompatible with Debian's libmozjs-dev which provides mozilla-js.pc

Michel Briand michelbriand at free.fr
Wed Sep 24 09:53:01 UTC 2008


Public bug reported:

Binary package hint: libmozjs-dev

I'm trying to package a software that needs libmozjs.

On Debian I get my package to build with

pkg-config [...] mozilla-js

But on Ubuntu the provided .pc file is different. Which renders the
build system incompatible.

libmozjs-dev on Ubuntu should rename the .pc file the same as Debian.

** Affects: xulrunner (Ubuntu)
     Importance: Undecided
         Status: New

-- 
libmozjs-dev provides xulrunner-js.pc which is incompatible with Debian's libmozjs-dev which provides mozilla-js.pc 
https://bugs.launchpad.net/bugs/273905
You received this bug notification because you are a member of Mozilla
Bugs, which is subscribed to xulrunner in ubuntu.




More information about the Ubuntu-mozillateam-bugs mailing list