[Bug 193846] Re: Office Communicator web access shows blank page

Shannon VanWagner shannon.vanwagner at gmail.com
Fri Aug 22 17:03:43 UTC 2008


Something I've found is that the Communicator Web Access works if the
"user agent" is switched to Win/IE7. Although the switch has to be
performed only in the child popup window(the one that has the contacts),
and to do this you have to "customize" the toolbar of the child window
to have the user-agent switcher icon on it. If you change the user agent
at the login window, you will not be able to launch the popup window
(this is very screwy eh?).

if you want to load the Firefox "User Agent Switcher" plugin, get it here:
https://addons.mozilla.org/en-US/firefox/addon/59 

So although this will make the communicator work in Firefox 3.0, I don't
use this method myself because I don't want to cloak the fact that I am
using GNU/Linux and Firefox. This reason is entirely political on my
part because I want to show as many webservers out there as possible
that I am using GNU/Linux and Firefox to surf the web.

After examining the "overall.js" javascript file that appears to control
the Office communicator website experience, it seems there is a function
there that checks for a win/IE platform(as well as other browsers and
mac), and I would suspect that since Firefox 3 does not validate as a
"known" browser to the javascript, it is breaking the functionality of
the program in Firefox 3. This is just silly because as soon as I switch
the "user agent" to win/IE7, the program works just fine in FIrefox 3.

Shannon VanWagner
http://healthysystem.blogspot.com

Get your cool GNU/Linux shirt here:
http://free.spreadshirt.com

-- 
Office Communicator web access shows blank page
https://bugs.launchpad.net/bugs/193846
You received this bug notification because you are a member of Mozilla
Bugs, which is a bug assignee.




More information about the Ubuntu-mozillateam-bugs mailing list