[Bug 173966] Re: java plugin not working in firefox 3 on ubuntu 8.04

echoes trust.no.1.xf at gmail.com
Fri Apr 11 21:56:14 UTC 2008

@ John Vivirito
ok, i tried that and go this output:
No alternatives for /usr/lib/jvm/java-6-openjdk/jre/lib/i386/gcjwebplugin.so.

then i realized that the "alternative" must be a file in the
/etc/alternatives dir.  (which makes sense. ;) give me a break, i've
never used update-alternatives before).

so i only found one java plugin in there, so then i tried:
sudo update-alternatives --set xulrunner-1.9-javaplugin.so javaplugin_oji
and got:
update-alternatives: Cannot find alternative `javaplugin_oji'.
(which i'm sure means i don't have that file (javaplugin_oji.so) on my system.  an mlocate search didn't reveal one either).

so then i noticed that i had copied gcjwebplugin.so file to
/usr/lib/mozilla/plugins (where it wasn't being detected by fx).  so
then i thought, i'm 99% sure i tried this before but i'll try it again
any way.  i copied the file (gcjwebplugin.so) to
/usr/lib/firefox/plugins and voila!  it now shows up in about:plugins.

but for some reason it still isn't showing up in konqueror's
about:plugins.  is there something that hasn't been implemented yet that
makes it incompatible with konqueror?

java plugin not working in firefox 3 on ubuntu 8.04
You received this bug notification because you are a member of Mozilla
Bugs, which is subscribed to firefox in ubuntu.

More information about the Ubuntu-mozillateam-bugs mailing list