[Bug 94021] Trying with Valgrind

Nicolas_Raoul junkiemail at altern.org
Thu Mar 22 21:58:06 UTC 2007


I am trying to reproduce the crash when Firefox is running with
Valgrind, with no luck so far, I could not reproduce it.

I suspect that launching firefox from an X terminal changes the behavior
of the whole thing, maybe the X terminal gets terminated too soon for
the bug to happen or something. I need this terminal to give Firefox its
Valgrind settings.

So I tried added a "&" at the end of the command line, not better.
I tried with "nohup command &":

nohup "G_SLICE=always-malloc G_DEBUG=gc-friendly  valgrind -v
--tool=memcheck --leak-check=full --num-callers=12 --log-
file=valgrind.log /usr/bin/firefox" &

but it does not work:
nohup: cannot run command `G_SLICE=always-malloc G_DEBUG=gc-friendly  valgrind -v --tool=memcheck --leak-check=full --num-callers=12 --log-file=valgrind.log /usr/bin/firefox': No such file or directory

I tried encapsulating the command in "" {} () no luck so far :-(
Anybody has any idea how to run a command in Valgrind so that it does not get terminated when X closes the terminal ?

How I do now is: I type CTRL+ALT+F1 to get a terminal out of X, redirect
the DISPLAY variable to :0.0, run /usr/bin/firefox in its Valgrind
command line, and then I come back to X11, open
http://www.jamendo.com/fr/jamplayerweb/, play some music and log out. I
tried this twice, no crash so far :-(

I will be working in Malta from tomorrow, and in Poland the week after,
so I probably won't be as responsive as usual, but I will try my best !

Happy bug hunting,
Nicolas.

-- 
firefox crash on logout, may be flash-nonfree
https://launchpad.net/bugs/94021




More information about the Ubuntu-mozillateam-bugs mailing list