[Bug 121413] Re: eclipse reports memory corruption, crashes

Bogdan Butnaru bogdanb+launchpad at gmail.com
Wed Jun 20 23:06:02 UTC 2007

OK, so I tried creating a new workspace, with the bug "enabled" (ie, the
libmozjs file in the normal position), Eclipse crashed. So I hid
(renamed) the file as described above, started Eclipse again, created a
workspace (it worked), stopped Eclipse, and put the file back. Then:

(1) I Started Eclipse (with the new, blank workspace),
(2) created a new Java project (named test),
(3) created a new class named Test, in package test.
(4) In the body of the class I started typing "Str" and pressed Ctrl-Space for the auto-completion.
(5) Eclipse worked the hard drive a bit, the little drop-box with the possible completions showed up, and a couple of seconds later Eclipse crashed. In quick succession:
    a. The error message appeared in the console (the one with "#" at the start of the lines);
    b. The Eclipse window disappeared;
    c. The dialog box that Eclipse shows on crashes appeared (see the contents below).

The exact same thing happens in any case when I press Ctrl+Space (and
also on automatic autocomplete), in any class in any project. It does
happen in other situations, too (like when I switch to a _new_ project,
not one that exists already). And the error is with the same file, as
far as I can tell. (Note, however, that the gslice/memory warning
appears right when Eclipse starts.)

JVM terminated. Exit code=1
-jar /usr/lib/eclipse/startup.jar
-os linux
-ws gtk
-arch x86
-launcher /usr/lib/eclipse/eclipse
-name Eclipse
-showsplash 600
-exitdata 420013
-install /usr/lib/eclipse
-vm /usr/lib/jvm/java/bin/java
-jar /usr/lib/eclipse/startup.jar

eclipse reports memory corruption, crashes
You received this bug notification because you are a member of Mozilla
Bugs, which is a bug contact for firefox in ubuntu.

More information about the Ubuntu-mozillateam-bugs mailing list