ubuntu (apt) specific bug in package xmobar

bjarki at vivaldi.com bjarki at vivaldi.com
Tue Oct 24 15:18:37 UTC 2023


Greetings

It would seem ReCaptcha wants me to single handedly retrain their image 
recognition AI before I can confirm my E-mail to be able to file this 
through your bugreporting system.

The xmobar package is broken, it is missing the libraries in order to 
compile .hs configurations for xmobar, and it appears to be reading the 
files incorrectly.


Once I have a ~/.xmobar/xmobar.hs file and run "xmobar" I get the 
following error:

Steps to reproduce:
sudo apt install xmobar
mkdir ~/.xmobar
#just get any xmobar.hs configuration file, this was the first I found 
online.
wget https://raw.githubusercontent.com/Vonr/xmobar/master/xmobar.hs
xmobar

Expected behaviour:
   Xmobar starts, running the configuration in ~/.xmobar/xmobar.hs

Actual behaviour:
   xmobar outputs the following on the error buffer and exits:
--------------------------------------------------------------------------------------
Error detected while loading xmobar configuration file: 
/home/bjarki/.xmobar/xmobar.hs
ghc: no input files
Usage: For basic information, try the `--help' option.

Please check the file for errors.
--------------------------------------------------------------------------------------

Note that this is not a regression but has been an issue with the apt 
package for a while.


-- 

Regards
Dr. Bjarki Geir Benediktsson



More information about the Ubuntu-motu mailing list