Call for Testing: Java Applications with OpenJDK7

James Page james.page at ubuntu.com
Fri Sep 21 10:03:17 UTC 2012


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

Hi All

For Quantal the default implementation of Java has been switched from
OpenJDK 6 to OpenJDK 7 in-line with objectives agreed in [1].

This basically means that if you install
default-[jdk|jre|jre-headless] or you install OpenJDK 6 and 7 then
Ubuntu will prefer OpenJDK 7 by default.

This is an important change as OpenJDK 7 is much more closely aligned
with Oracle Java 7; performance and compatibility should be comparable
on x86 based architectures.

This change has been in place for some time now but as we approach
Beta-2 it would be great if anyone who uses Java on a regular basis,
either for development or to run applications, could do some more
extended testing to ensure that this transition is still going nice
and smoothly.  If you find any problems please report bugs and tag
with 'java7-regression-potential'.

We still have a few outstanding FTBFS with OpenJDK 7 as default Java -
see [2] if you have some time to help out.

There are also have a large number of potential bytecode compatibility
issues (packages which build with OpenJDK 7 but don't set the flags to
ensure that the code built is compatible with Java 6 as well) - see
[3] for the full list of impacted packages which when re-built exhibit
this problem.  I'm also in the progress of assessing the binary
packages already in the archive for quantal which might already have
this issue (which should be fixed as a priority).

See [4] for more details on how to resolve both of these types of issues.

Thanks in advance for any time you can spare either testing or fixing
bugs.

Cheers

James


[1] https://blueprints.launchpad.net/ubuntu/+spec/foundations-q-java7
[2] https://bugs.launchpad.net/ubuntu/+bugs?field.tag=java7-ftbfs
[3] https://bugs.launchpad.net/ubuntu/+bugs?field.tag=java7-bytecode
[4] https://wiki.ubuntu.com/JavaTeam/Java7Default
- -- 
James Page
Ubuntu Core Developer
Debian Maintainer
james.page at ubuntu.com
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.11 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://www.enigmail.net/

iQIcBAEBCAAGBQJQXDtlAAoJEL/srsug59jDjw8QAKDQYnmIjU2CvRy9tVPCUtQn
fMC7ULOOeosajsRVGLEBw0I2zMt+zbuVKOTPUw5DobNRaYOSQ79p1B3iC7nl4Ld3
MxaovKEvXWqGWXd+0shTxDf2tOOhMztYHBbz53Qjvar57Oa7Q15MYMyJIAt3UXsA
4SW2BBdE9MiqbDIrwhOX7rauXw+SesbjwK8D1avhbd7KgE2K0HSe7C+PPhxj3iMv
3lJW5yIf5qNvCrq9Mf/xpjID9E6GtGYXyndghHHFbouzkhHtdwPxm+9EgQDWEuUc
clX173cQBDd7SpvJ206JghKGfFwUIYZ71xo41QwUC0r6E+l6ket+aid/VfKvqKcB
tlh+w9EPKthl4IInVsNkzGXIX98zvX/T920u5+rh0ZGLYpB4nWjaFKSAHUh7Pmdw
u8D7z9zMeDblT41wGrFKIcpdrPLQplr+kqAafzErT7lbivGmePeUamGg8SDE2q/R
S5Qrp+SYOba84VWnd5w/9wcJJ+PBuIKlWawSRldpZUezVa9KqRhqDhaKq4tTXjIm
WfvY0Tw0D9mxVQIKw0JTTkELpJEyUWkNXiBCNxNJvPnHm87+i+E0HEl7GY4G6g3M
PyN3jd4RzUidTNHfFd9VzKhVpFTkuvYhJZYMPrVI+PPgn3oWG78OUmwwFKUehGqe
9SnS9KRhmSqPHOQrjVFO
=BZLq
-----END PGP SIGNATURE-----



More information about the Ubuntu-motu mailing list