CDO software bug

marcofgalli at marcofgalli at
Sat Nov 10 23:45:13 UTC 2012

Dear Ubuntu MOTU team,

I'm writing you because I would like to help with a problem I found in one
of the software packages available in the standard official Ubuntu
repositories. I fount out that the problem is a compilation problem
specific of the software coming with Ubuntu due to an unsatisfactory
compilation, as I will demonstrate in the text of this email of mine.

I already opened a bug report on Launchpad, but nobody gave ever a feedback
about that. I opened that bug report because of a malfunctioning of the cdo
software available in the homonymous package in the Ubuntu official
repositories. I have the technical skills to get the problem fixed for
myself, but I'd like to share the fixing of the problem with the other
people of the Ubuntu community. About this point, I'd need some tutoring on
how to do the work of sharing the solution of the problem and let the other
users benefit of that. I both can warn you of this problem, or, if you
don't have time to fix it personally, I can do it, but, as I was writing
before, I'd need some tutoring.

Some time ago, I noticed a problem with the software cdo. At first, I did
not know how to classify it, if the name of the problem could be referred
meaningfully with the word bug or not. However, I investigated a little
about this problem I found out, and I worked out it was a compilation
problem of the cdo package ( shipping
with Ubuntu. The Ubuntu cdo software works, strictly speaking (i. e., it
does not suffer of memory leaks, or it does not lead to segmentation
faults, it does not crash if I feed it with meaningful input...). However,
the cdo software does not always to what it is supposed to do. The problem
is not intrinsic in the software itself: in fact, if one compiles the
source package after downloading it directly from the developers web site
(which I referenced above), everything works perfectly. My question is: how
is it possible to correct the misfunctioning of the software in the Ubuntu

My report on Launchpad is this one:

For my own curiosity, I tried to use cdo in the framework of a Debian
powered computer system, because I was convinced that Ubuntu inheired most
of the software packages from it, and, most of all, this non
distribution-specific software packages (i. e., cdo does not appear to use
any specific Debian or Ubuntu logo...). I surprisingly found out that in
Debian everything works perfectly. Hence, the problem in the cdo software
is due to some errors of who compiled and packaged it for Ubuntu. In
detail, as it resulted from my investigation, the Ubuntu packager used and
linked a library not yet fully supported (as a reference, hereafter, I'm
posting my discussion with the upstream software developer:

How do I have to move to get the problem solved? I made the software work
for myself, recompiling it from scratch, but I'd like to share my solution.

I am more than keen to write more specific details, it you need them. In
this report, in fact, I reckon (perhaps erroneously?) not necessary to go
into what cdo does and does not do in its official version distributed with

I already opened a bug report on the Italian forum of the Ubuntu developers
team ( ;
in italian language), and I have been suggested to contact the Ubuntu
maintainer of the package (you, as I understood) to ask about this problem.

More in the technical details, the version shipping with Ubuntu uses the
grib_api library to cope with the grib1 and grib2 files. The cdo upstream
package internal library for grib1 files is not used at all in the Ubuntu
version, and it is the only functioning library for grib1 files, as it
results from the discussion I referred above with the cdo software
developer. However, the grib_api library is needed as well, because it is
the only interface available to cope with grib2 data files.

<>In the
meanwhile, I upgraded my Ubuntu distribution from the 12.04 to the 12.10,
but nothing about this issue happened. We have to work about this.

I know that not many people use this software, and many of the users are so
skilled that they can overcome the problem by themselves; however, I do not
think this is a good reason not to fix this bug. I had the chance to
interact to many younger colleagues that are not so familiar with the
GNU/Linux systems, nor with their management. These people get so annoyed
and discouraged when this kind of (very trivial) problems come out, and
this is not a really good advertising for their idea about free software.
They usually get somebody (I'm one of them) which lets things work,
however, if Ubuntu is Linux for human beings, also this specialistic
software should work good as well.

Thanks in advance for the attention. Don't exitate to contact me for some
interaction, for some guidance on how to behave, for some tutoring on how
to act personally to fix the problem, if you cannot do that personally.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the Ubuntu-motu mailing list