gnu-smalltalk amd64 missing

Roland Plüss roland at rptd.ch
Wed Feb 23 12:38:43 UTC 2011


Am 18.02.2011 13:38, schrieb Chow Loong Jin:
> On Friday 18,February,2011 08:02 PM, Roland Plüss wrote:
>> Am 16.02.2011 18:33, schrieb Chow Loong Jin:
>>> On Wednesday 16,February,2011 07:00 PM, Roland Plüss wrote:
>>>> Since nearly over a year now the gnu-smalltalk is broken on Ubuntu (since
>>>> maverick to be precise) on my amd64 developer machine. Since this time I have
>>>> now to dual-boot with a GenToo to develop with GST since Ubuntu only has the
>>>> i368 version but not the amd64 version.
>>>>
>>>> Why exactly is there no amd64 version since over a year whereas GenToo has an
>>>> amd64 version and it works splendid? Is it because of this one test case which
>>>> fails in the build logs?
>>>>
>>>>>    111: DBD-MySQL                                       skipped
>>>>> (testsuite.at:149)
>>>>>    116: GDBM                                            FAILED
>>>>> (testsuite.at:154)
>>>>>
>>>>>    ERROR: 125 tests were run,
>>>>>    1 failed unexpectedly.
>>>>>    1 test was skipped.
>>>> A skipped test is nothing special and GDBM failing the test by itself also
>>>> nothing special (it's under "other package"). Is it not possible to do something
>>>> about this? It's quite a nuisance to dual-boot just because an amd64 version is
>>>> refused to be done.
>>>>
>>>> (if you answer on this mail, please also CC roland at rptd.ch as I can't register
>>>> on this mailing list for some reason)
>>>>
>>> Sorry about that. It's not that the amd64 version is refused to be done, but
>>> more like nobody who used the package stepped forward to fix it (just a
>>> no-change re-upload, since the tests all pass now anyway).
>>>
>>> There's a bug on this[1], and I've just uploaded an unchanged package to the
>>> maverick-proposed queue. Please subscribe yourself to that bug, and when the
>>> package gets approved for the -proposed queue (and subsequently get copied into
>>> natty), please verify that it works fine on Maverick so that users may get it
>>> via maverick-updates.
>>>
>>> Thanks for the notifying us about this.
>>>
>>>
>>> [1] https://bugs.launchpad.net/ubuntu/+source/gnu-smalltalk/+bug/712296
>>>
>> I would do so but unfortunately my launchpad account there is broken. I can't
>> log in anymore and it seems not fixable so can't help with anything involving
>> launchpad. Besides I'm afraid you would have to guide me there with this
>> proposed queue and testing stuff. I'm used to create and work with ebuilds but
>> with Ubuntu I have no clue.
> Follow the instructions here, and install gnu-smalltalk from maverick-proposed
> (if you're using Maverick) or from lucid-proposed (if you're using Lucid). If
> you're using Natty, just do nothing and wait.
>
> https://wiki.ubuntu.com/Testing/EnableProposed
>
Sorry for the delay but I had been quite busy. I tried getting this 
working but I can't. I get to the point where I added the masking of the 
proposed repository but installing does not work. KPackageKit does not 
recognize the -t parameter nor does it show the proposed packages. I 
can't seem to get it installed this way.



More information about the Ubuntu-motu mailing list