petsc FTBFS...

Steven Susbauer steven at
Wed Jun 3 20:12:04 BST 2009

Good day,

I recently had a petsc merge uploaded to universe. It built fine for me
and previously in my ppa but now fails on arch other than lpia (it
appears). I believe it may be a simple error, either on my side or the
build system, but want to check.

The error appears to be related to the build-depends:

Build-Depends: debhelper (>= 3.0), quilt, python (>= 2.2), gfortran,
libx11-dev, mpi-default-dev, mpi-default-bin [!lpia], openmpi-bin
[lpia], libblas-dev |, liblapack-dev |,
libsuitesparse-dev (>= 3.1.0-2), libsuperlu3-dev (>= 3.0+20070106),
libspooles-dev (>= 2.2-6), libhypre-dev (>= 2.4.0), libscotch-dev,
babel-1.2.0 | babel [!arm !alpha !s390 !hppa], libsidl-dev (>=
1.2.0.dfsg-5) [!arm !alpha !s390 !hppa]

The following packages have unmet dependencies:
  mpi-default-bin: Depends: openmpi-bin but it is not going to be installed
  mpi-default-dev: Depends: libopenmpi-dev but it is not going to be
E: Broken packages

I explicitly enabled openmpi-bin for lpia because mpi-default-bin fails
during the actual build. By doing this did I disable bringing in
openmpi-bin to satisfy the mpi-default-bin dependency for other
architectures? Any reason why the build system wouldn't try to satisfy
this dependency, other than that?


-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 260 bytes
Desc: OpenPGP digital signature
Url : 

More information about the Ubuntu-motu mailing list