Structural problem with Sun Java JRE

Pjotr pliniusminor at gmail.com
Tue Aug 18 11:04:42 BST 2009


Hello,

Hereby I request your attention for the following matter. It concerns
Multiverse and not Universe, but the matter is grave enough to bring
this to your attention.

Sun Java JRE doesn't receive security updates for Hardy, Intrepid and
Jaunty. The latest security update is only for Karmic. This is a huge
problem. A structural problem as well: this is not the first time that
Sun Java JRE security updates aren't ported to current stable Ubuntu
versions.

OpenJDK still can't replace JRE entirely. There are still some
websites that only function well for a visitor, when that visitor has
JRE installed. A pity, but that's how it is. And that's why we need
security updates for JRE: most desktop users have it installed on
their computers. We can't leave them unprotected.

All that has to be done for the current JRE security update
(1.6.0_15), is to make the Karmic JRE packages available for Hardy,
Intrepid and Jaunty. No change necessary. So this can be done very
easily and quickly.

If you already have installed Sun Java JRE from Multiverse in 8.04,
8.10 or 9.04, then all you have to do is install the Karmic packages
and it works fine. I already provided a workaround:
https://bugs.launchpad.net/ubuntu/+source/sun-java6/+bug/409559/comments/8

But that's only a workaround. Many people won't know it's available.
Therefore we need a regular security update. Plus we need a structural
change in the handling of security updates for Sun Java JRE: this is
not an incident. Can you make this happen?

This is the current bug report on Launchpad:
https://bugs.launchpad.net/bugs/409559

Greeting, Pjotr.



More information about the Ubuntu-motu mailing list