License clarification of faac

Reinhard Tartler siretart at ubuntu.com
Fri Aug 7 08:11:21 BST 2009


Hi,

It has been suggested to me that I should contact you and ask for
clarification for the license of faac. Allow me to introduce myself, I'm
both and Debian and Ubuntu Developer and maintain several multimedia
related packages in the Debian pkg-multimedia team. 

It has come to my attention that ffmpeg and x264 developers claim that faac
cannot be redistributed under the LGPL. According to my investigations,
this claim arises from using the following files:

 - libfaac/bitstream.c
 - libfaac/tns.c
 - libfaac/tns.h

All contain the following copyright notice:

This software module was originally developed by
and edited by Texas Instruments in the course of
development of the MPEG-2 NBC/MPEG-4 Audio standard
ISO/IEC 13818-7, 14496-1,2 and 3. This software module is an
implementation of a part of one or more MPEG-2 NBC/MPEG-4 Audio tools
as specified by the MPEG-2 NBC/MPEG-4 Audio standard. ISO/IEC gives
users of the MPEG-2 NBC/MPEG-4 Audio standards free license to this
software module or modifications thereof for use in hardware or
software products claiming conformance to the MPEG-2 NBC/ MPEG-4 Audio
standards. Those intending to use this software module in hardware or
software products are advised that this use may infringe existing
patents. The original developer of this software module and his/her
company, the subsequent editors and their companies, and ISO/IEC have
no liability for use of this software module or modifications thereof
in an implementation. Copyright is not released for non MPEG-2
NBC/MPEG-4 Audio conforming products. The original developer retains
full right to use the code for his/her own purpose, assign or donate
the code to a third party and to inhibit third party from using the
code for non MPEG-2 NBC/MPEG-4 Audio conforming products. This
copyright notice must be included in all copies or derivative works.

Copyright (c) 1997.

This issue is tracked publicly in the ubuntu bug tracking system at
https://launchpad.net/bugs/374900

I strongly suspect that this is not intended and there might either be a
misunderstanding or can be fixed otherwise easily.

Could you please state us you your opinion on the matter and advice us
how to proceed with the ubuntu package in ubuntu? If you don't mind, I'd
like to copy your answer to the bug referenced above.

Thanks for releasing faac under LGPL and thanks in advance for
considering this issue!

-- 
Gruesse/greetings,
Reinhard Tartler, KeyID 945348A4



More information about the Ubuntu-motu mailing list