JOSM in upcoming Ubuntu packages

Daniel Hahler ubuntu+lists at thequod.de
Tue Apr 14 22:01:29 BST 2009


Frederik Ramm:

>     I am writing to inform you that the OpenStreetMap editor package
> JOSM, which is issued by you and of which I am one of the upstream
> developers, is affected by the upcoming OpenStreetMap API update (from
> v0.5 to v0.6, scheduled for next weekend).
>
> Anyone using a JOSM version older than rev. 1525 will have to change the
> API version manually in a config file or else it will stop working.
>
> If you plan to package a JOSM version older than 1525 for any
> distribution that will be published after next weekend, it would be
> advisable to at least change the default for the configuration option
> "osm-server.version" to 0.6 in order to spare people the manual change.
> JOSM versions after 1525 should be able to work with 0.5 and 0.6 server
> versions.

Thanks for notifying us.

I've looked at the package in Ubuntu Jaunty (0.0.0.20080713-1ubuntu1) and it 
contains several instances of "osm-server.version", with both "0.5" and "0.6".
That's likely to be intended (I've not looked closer at the source, but its 
used to determine useChangeSets, and defaults to "0.5" there).

What change are you requesting? That instances of Main.pref.get("osm-
server.version") should default to "0.6"?

If it's not too much hassle for you (e.g. you need to create an account 
first), please create a bug at 
https://bugs.launchpad.net/ubuntu/+source/josm/+filebug (and feel free to 
subscribe me (blueyed)) there.

If I've understood you correctly, I could create a patch/fixed upload for 
this.

Please verify that the version in Ubuntu (0.0.0.20080713-1ubuntu1) is "after 
1525" (and therefore the change needs to get applied).


Thanks,
Daniel
-- 
http://daniel.hahler.de/
-------------- next part --------------
An HTML attachment was scrubbed...
URL: https://lists.ubuntu.com/archives/ubuntu-motu/attachments/20090414/263b4740/attachment.htm 
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: This is a digitally signed message part.
Url : https://lists.ubuntu.com/archives/ubuntu-motu/attachments/20090414/263b4740/attachment.pgp 


More information about the Ubuntu-motu mailing list