JOSM in upcoming Ubuntu packages

Frederik Ramm frederik at
Mon Apr 13 19:15:50 BST 2009

Dear MOTU developers,

    I am writing to inform you that the OpenStreetMap editor package 
JOSM, which is issued by you and of which I am one of the upstream 
developers, is affected by the upcoming OpenStreetMap API update (from 
v0.5 to v0.6, scheduled for next weekend).

Anyone using a JOSM version older than rev. 1525 will have to change the 
API version manually in a config file or else it will stop working.

If you plan to package a JOSM version older than 1525 for any 
distribution that will be published after next weekend, it would be 
advisable to at least change the default for the configuration option 
"osm-server.version" to 0.6 in order to spare people the manual change. 
JOSM versions after 1525 should be able to work with 0.5 and 0.6 server 


Frederik Ramm  ##  eMail frederik at  ##  N49°00'09" E008°23'33"

More information about the Ubuntu-motu mailing list