svk admin: buggy option handling?

Paolo Giarrusso p.giarrusso at
Thu Aug 16 12:23:05 BST 2007

I'm using Ubuntu 7.04 svk, i.e. 1.08 (package version 1.08-2ubuntu1)

I've tried using svk admin setlog, but it didn't accept -r:

$ svk admin setlog -r 920 ciao
Unknown option: r
Unknown options.

$ svk admin setlog  ciao
svnadmin: Revisione mancante
// Means "svnadmin: Missing revision"

$ svk admin setlog -r920 ciao
Unknown option: r
Unknown option: 9
Unknown option: 2
Unknown option: 0
Unknown options.

I solved the problem by using svnadmimn, and after 
reading /usr/share/perl5/SVK/ 
and /usr/share/perl5/SVK/Command/, I've thought that it maybe 
happened because has an empty option list, so the general 
infrastructure saw that -r is not between the allowed options.

To Chia-liang Kao: is this fixed in later releases? To Debian and Ubuntu 
maintainers: could the fix be backported?

Thanks for your attention.
"Doh!" (cit.), I've made another another mistake!
Paolo Giarrusso, aka Blaisorblade
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: This is a digitally signed message part.
Url : 

More information about the Ubuntu-motu mailing list