rebuilds for libssl0.9.7 -> libssl0.9.8

Michael Bienia michael at vorlon.ping.de
Fri Oct 13 15:42:37 BST 2006


On 2006-10-13 06:15:27 +0200, Stefan Potyra wrote:
> Hi Kees,
> 
> Am Freitag 13 Oktober 2006 00:45 schrieb Kees Cook:
> > sope: build-dep conflicts:
> >  The following packages have unmet dependencies:
> >    apache-dev: Depends: libdb4.4-dev but it is not going to be installed
> > This totally baffles me.  I can install the build-dep by hand without
> > any problem, but within my sbuild environment, it breaks as above.  Any
> > clues on how to solve this?
> 
> sope -> libdb4.4-dev, apache-dev, apache2-threaded-dev
> apache2-threaded-dev -> libdb4.3-dev
> apache-dev -> libdb4.4-dev
> 
> and both libdb4.4-dev and libdb4.3-dev provide libdb-dev and conflict against 
> libdb-dev, so you cannot install the build-dependencies together. Seems like 
> you currently cannot build apache2 and apache modules from the same source.

php4 is in the same situation (build-depending on libdb4.3-dev and
libdb4.4-dev). AFAIK Adam Conrad is working on it. Probably he will
build apache against libdb4.3-dev. Once this is solved for php4, sope can
also be rebuild.

Michael



More information about the Ubuntu-motu mailing list