need some help with a new package

David Sugar dyfet at
Fri Apr 3 20:34:35 BST 2009

I thought I would comment on this question.

First, you do not need to go all the way to pbuilder to find what went
wrong.  After debuild, you can run dpkg -c on the resulting locally
produced deb, and see immediately that there is no "ftimes" files in
/usr/bin in that deb.

The core problem is this package's use of rather non-standard Makefile
arrangement.  Running "debuild" I already see things like:

make[2]: Entering directory `/home/dyfet/tmp/ftimes-3.8.0/src'
/usr/bin/install: cannot create regular file `/usr/bin/ftimes':
Permission denied

This is because install paths are effectively "hardcoded" from configure
time.  While there is a "INSTALL_PREFIX=${PREFIX}/bin" in
src/, unfortunately PREFIX = @prefix@, which means it cannot
be changed later for the producing the install target.  Hence, when
debuild uses:
  make prefix=.../debian/ftimes/usr install

You could change debian/rules to use:

  	$(MAKE) PREFIX=$(CURDIR)/debian/ftimes/usr
etcdir=$(CURDIR)/debian/ftimes/etc install

in place of "make prefix=$(CURDIR) install" in the install: target.

and this will get you closer.  There may be other issues in this
packages Makefile's though :).

Donald Raikes wrote:
> I am just starting to work with ubuntu packaging, and have several
> opensource application which I wish to create packages for.
> I started with the ftimes program <>
> I downloaded the source tarball, unpacked it and ran dh_make on it. I
> edited the necessary files in the debian folder, and ran debduild to
> create the .dsc file. I next ran pbuilder --build on the .dsc file, and
> after a few iterations and adding some packages to my chroot
> environment, it compiled fine and generated the source and binry
> packages.
> Next I ran sudo dpkg -i ftimes_3.8.0-0ubuntu1.deb, and it says it was
> setup, but I cannot find any evidence of the program on my system. I ran
> updatedb and then did a locate ftimes and it onlly finds the sources and
> the pbuilder results.
> How can I figure out what is going wrong with my package?
> Any tips/pointers would be appreciated.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: dyfet.vcf
Type: text/x-vcard
Size: 177 bytes
Desc: not available
Url : 

More information about the Ubuntu-motu-mentors mailing list