Help with packaging Herwig++. Won't build.

Joseph Smidt josephsmidt at gmail.com
Thu Nov 20 21:46:51 GMT 2008


Hello,

     I am new at packaging and would like to become motu once I get good at
it.  In the meantime I am trying to package various science packages
used in high energy physics and could use some help with Herwig++.  The
package can be viewed from my PPA:  https://launchpad.net/~jsmidt/+archive.

     The problem with the package is it won't build.  I get this error:

dpkg-shlibdeps: failure: no dependency information found for
/usr/lib/ThePEG/libThePEG.so.6 (used by
debian/herwigpp/usr/bin/Herwig++).
dh_shlibdeps: command returned error code 512
make: *** [binary-arch] Error 1

     I don't know what "dh_shlibdeps: command returned error code 512"
means. Furthermore I am confused it complains about no dependency on
ThePeg since I have it as a dependence in the control file.

Could someone look at my packages and point me in a direction to get
this compiled. I would really appreciate it. Thanks.


                         Joseph Smidt

--
Joseph Smidt <josephsmidt at gmail.com>

Physics and Astronomy
4129 Frederick Reines Hall
Irvine, CA 92697-4575
Office: 949-824-2630



More information about the Ubuntu-motu-mentors mailing list