[ubuntu-mono] [Bug 778602] Re: Banshee-plugin not working

A.T.J. 778602 at bugs.launchpad.net
Wed Jan 4 15:18:46 UTC 2012

Had the same issue on Lucid, this workaround worked for me

You received this bug notification because you are a member of Ubuntu
CLI/Mono Uploaders, which is subscribed to gnome-do-plugins in Ubuntu.

  Banshee-plugin not working

Status in “gnome-do-plugins” package in Ubuntu:

Bug description:
  Binary package hint: gnome-do-plugins

  The banshee-plugin in natty (11.04) does not work with banshee 2.0. It
  references /usr/lib/banshee-1 for some reason. When starting gnome-do
  I get the following error:

  WARNING: [Do.Banshee,1.0] Could not load some add-in assemblies: File 
  '/usr/lib/banshee-1/Banshee.CollectionIndexer.dll' not found.
  ERROR: Errors found in add-in '/usr/lib/gnome-do/plugins/Banshee.dll:
  ERROR: The file '/usr/lib/banshee-1/Banshee.CollectionIndexer.dll' referenced 
  in the manifest could not be found.

  Everything worked fine in ubuntu 10.10 with Banshee 2.0 from ppa.

  The following workaround appears to work:

   - Uninstall gnome-do and gnome-do-plugins
   - Download gnome-do, gnome-do-plugins and libgdata1.4-cil from maverick (can be done from packages.ubuntu.com) and install them. 
   - Start Synaptic, search for "gnome-do" and do a "Lock version" on both gnome-do and gnome-do-plugins.
   - Remove .local/shares/gnome-do in your home directory.
   - Do a symbolic link from /usr/lib/banshee to /usr/lib/banshee-1
   - Start gnome-do and activate the banshee plugin.

To manage notifications about this bug go to:

More information about the Ubuntu-mono mailing list