[ubuntu-mono] [Bug 882501] Re: Mono crashes while executing mono + Gtk# applications

baltasarq baltasarq at yahoo.es
Thu Oct 27 10:38:44 UTC 2011


The crash information is as follows, being tacto.exe a moo application
created with Monodevelop:

$ mono tacto.exe 
Gtk-Message: Failed to load module "canberra-gtk-module"
Missing method System.Type::op_Inequality(Type,Type) in assembly /usr/lib/mono/2.0/mscorlib.dll, referenced in assembly /usr/lib/mono/gac/gtk-sharp/2.12.0.0__35e10195dab3c99f/gtk-sharp.dll

Unhandled Exception: System.MissingMethodException: Method not found: 'System.Type.op_Inequality'.
  at Tacto.Gui.MainWindow..ctor () [0x00000] in <filename unknown>:0 
  at Tacto.MainClass.Main (System.String[] args) [0x00000] in <filename unknown>:0 
[ERROR] FATAL UNHANDLED EXCEPTION: System.MissingMethodException: Method not found: 'System.Type.op_Inequality'.
  at Tacto.Gui.MainWindow..ctor () [0x00000] in <filename unknown>:0 
  at Tacto.MainClass.Main (System.String[] args) [0x00000] in <filename unknown>:0

-- 
You received this bug notification because you are a member of Ubuntu
CLI/Mono Uploaders, which is subscribed to mono in Ubuntu.
https://bugs.launchpad.net/bugs/882501

Title:
  Mono crashes while executing mono + Gtk# applications

Status in “mono” package in Ubuntu:
  New

Bug description:
  Platform: Intel x32 + Ubuntu Oneiric 11.10
  Package version: 2.10.5-1

  This error is still present in Ubuntu Oneiric for mono applications
  created with monodevelop and using Gtk#, but not, for some reason,
  applications bundled with the operating system.

  The same happened to me in Windows, and the problem disappeared
  upgrading to the current version of Mono (2.10.6). I guess this is
  going to be the same thing.

  Unfortunately, recompiling applications is not an option, as
  Monodevelop 2.6 is unable to find the Gtk# in the system (?). Again,
  the same happened to me in Windows, and upgrading to the current
  version of MonodeDevelop (2.8) solved the problem.

  Would it be possible to upgrade these packages to their current versions, so this bugs disappear?
  If not, how can I solve this in my system, so I'm able to use mono again?

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/mono/+bug/882501/+subscriptions



More information about the Ubuntu-mono mailing list