[ubuntu-mono] [Bug 864829] Re: GTK bindings built for 4.0 runtime are incompatible with applications built for 2.0 runtime

Launchpad Bug Tracker 864829 at bugs.launchpad.net
Thu Oct 20 15:13:45 UTC 2011


Status changed to 'Confirmed' because the bug affects multiple users.

** Changed in: gtk-sharp2 (Ubuntu)
       Status: New => Confirmed

-- 
You received this bug notification because you are a member of Ubuntu
CLI/Mono Uploaders, which is subscribed to gtk-sharp2 in Ubuntu.
https://bugs.launchpad.net/bugs/864829

Title:
  GTK bindings built for 4.0 runtime are incompatible with applications
  built for 2.0 runtime

Status in “gtk-sharp2” package in Ubuntu:
  Confirmed

Bug description:
  This package is built for 4.0 runtime instead of 2.0. It breaks
  compatibility with 2.0 runtime and makes impossible to run some old
  software targeted 2.0 runtime.

  
  Just change CSC=/usr/bin/mono-mcs to CSC=/usr/bin/gmcs in debian/rules file and it will generate binaries compatible both with 2.0 and 4.0 runtimes.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/gtk-sharp2/+bug/864829/+subscriptions



More information about the Ubuntu-mono mailing list