[ubuntu-mono] [Bug 882501] Re: Mono crashes while executing mono + Gtk# applications

baltasarq baltasarq at yahoo.es
Thu Nov 3 09:01:55 UTC 2011


Thanks for your interest. I had reached to the very same web pages by
myself (it seems they are the only ones talking about this problem). I
don't think this means that the bug is solved, though. The mono CLI
should be able to run apps compiled for the .NET 3.5 profile, or mono
CLI 2.0, not only mono CLI 4.0.

If you do a apt-cache search mono:

$ apt-cache search libmono
...
libmono-system2.0-cil - Mono System libraries (for CLI 2.0)
libmono-system4.0-cil - Mono System libraries (for CLI 4.0)
libmono2.0-cil - Mono libraries (for CLI 2.0)
...

i.e, the mono libraries for 2.0 are there. More over, mono has not the
"right" to choose whether to run an application or not based on the
profile (.NET 3.5/.NET 4.0) it was compiled. In order to be compliant,
mono should still run apps for .NET 1.0 (if such thing does still
exist), and not crash with a strange error saying that some method that
obviously should be there is not found.

Probably the bug has to do with mono being unable to change to the CLI
2.0 profile when executing a CLI 2.0 app. Surely the problem is that it
is unable to choose the right CLI depending to which one the app was
compiled against.

Also, the problem with MonoDevelop still persists... it is actually
useless, for Gtk# apps, as it is. Well, actually I was able to compile
and run without problems a project which is not using Gtk# (it uses the
SDL lib), ans which was targeting the .NET 3.5 (CLI 2.0) profile (?).

I honestly think that all of this would be solved at once just by
upgrading Monodevelop and Mono versions. I know because, as I said, I
had the same misterious problems in Windows, and upgrading solved them.

-- 
You received this bug notification because you are a member of Ubuntu
CLI/Mono Uploaders, which is subscribed to mono in Ubuntu.
https://bugs.launchpad.net/bugs/882501

Title:
  Mono crashes while executing mono + Gtk# applications

Status in “mono” package in Ubuntu:
  New

Bug description:
  Platform: Intel x32 + Ubuntu Oneiric 11.10
  Package version: 2.10.5-1

  This error is still present in Ubuntu Oneiric for mono applications
  created with monodevelop and using Gtk#, but not, for some reason,
  applications bundled with the operating system.

  The same happened to me in Windows, and the problem disappeared
  upgrading to the current version of Mono (2.10.6). I guess this is
  going to be the same thing.

  Unfortunately, recompiling applications is not an option, as
  Monodevelop 2.6 is unable to find the Gtk# in the system (?). Again,
  the same happened to me in Windows, and upgrading to the current
  version of MonodeDevelop (2.8) solved the problem.

  Would it be possible to upgrade these packages to their current versions, so this bugs disappear?
  If not, how can I solve this in my system, so I'm able to use mono again?

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/mono/+bug/882501/+subscriptions



More information about the Ubuntu-mono mailing list