[ubuntu-mono] [Bug 830217] Re: [FFe] Sync cecil, cecil-flowanalysis, db4o, mono.reflection from Debian unstable/experimental

Iain Lane iain at orangesquash.org.uk
Thu Aug 25 15:33:00 UTC 2011


laney at raleigh> syncpackage -d experimental db4o
syncpackage: Source db4o -> oneiric/Release: current version 7.4.121.14026+dfsg-3, new version 8.0.184.15484+dfsg-1
syncpackage: Downloading https://launchpad.net/debian/+archive/primary/+files/db4o_8.0.184.15484+dfsg-1.dsc
. done
syncpackage: Downloading https://launchpad.net/ubuntu/+archive/primary/+files/db4o_7.4.121.14026+dfsg-3.dsc
. done
Sync this package [y|N]? y
syncpackage: Request succeeded; you should get an e-mail once it is processed.


** Changed in: db4o (Ubuntu)
       Status: New => Fix Released

-- 
You received this bug notification because you are a member of Ubuntu
CLI/Mono Uploaders, which is subscribed to cecil in Ubuntu.
https://bugs.launchpad.net/bugs/830217

Title:
  [FFe] Sync cecil, cecil-flowanalysis, db4o, mono.reflection from
  Debian unstable/experimental

Status in “cecil” package in Ubuntu:
  Fix Released
Status in “cecil-flowanalysis” package in Ubuntu:
  Fix Released
Status in “db4o” package in Ubuntu:
  Fix Released
Status in “longomatch” package in Ubuntu:
  New
Status in “tangerine” package in Ubuntu:
  New

Bug description:
  Hi,

  db4o is one of the remaining items for the mono 2.10 transition that
  the Debian team is able to fix (binary removals for the others to come
  soon)

    http://people.canonical.com/~ubuntu-archive/transitions/mono.html

  The version in Oneiric currently doesn't have any support for the CLR
  4.0 which mono 2.10 is using. The new upstream version, 8.0, is needed
  for this. Unfortunately this also requires updating two of the
  dependencies (cecil & cecil-flowanalysis) to new upstream versions.
  Another new BD, mono.reflection, was needed too.

  All of these updates are complete in Debian already, so this will be
  finished in Ubuntu by way of syncs. cecil-flowanalysis is transitioned
  to an unstable (copied at build-time) library and will need binary
  NEWing. db4o has a new ABI and will also need binary NEWing.
  mono.reflection is a new source package so will need source and binary
  NEWing.

  I've tested they all build on Ubuntu. There are two reverse
  dependencies of this stack, tangerine and longomatch. Tangerine needs
  a two line patch which shall be uploaded to experimental today and
  synced when it becomes available. Longomatch will just need a rebuild.

  Summary

   - sync cecil cecil-flowanalysis mono.reflection db4o
   - source new mono.reflection
   - binary new cecil-flowanalysis mono.reflection db4o
   - sync tangerine
   - rebuild longomatch

  Sound OK? I can give you build, install, run evidence if you like.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/cecil/+bug/830217/+subscriptions



More information about the Ubuntu-mono mailing list