[ubuntu-mono] [Bug 651054] Re: CVE-2010-3365: insecure library loading

Launchpad Bug Tracker 651054 at bugs.launchpad.net
Tue Oct 5 17:04:09 BST 2010

This bug was fixed in the package mistelix - 0.31-0ubuntu1.1

mistelix (0.31-0ubuntu1.1) lucid-security; urgency=low

  * SECURITY UPDATE: insecure LD_LIBRARY_PATH redefinition (LP: #651054)
    - Add debian/patches/insecure-library-loading.patch
    - CVE-2010-3365
 -- Siegfried-Angel Gevatter Pujals <rainct at ubuntu.com>   Wed, 29 Sep 2010 13:28:29 +0200

** Changed in: mistelix (Ubuntu Lucid)
       Status: Fix Committed => Fix Released

** Changed in: mistelix (Ubuntu Karmic)
       Status: Fix Committed => Fix Released

CVE-2010-3365: insecure library loading
You received this bug notification because you are a member of Ubuntu
CLI/Mono Uploaders, which is subscribed to mistelix in ubuntu.

Status in “mistelix” package in Ubuntu: Fix Released
Status in “mistelix” source package in Lucid: Fix Released
Status in “mistelix” source package in Karmic: Fix Released

Bug description:
Binary package hint: mistelix

>From http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=598297:

Package: mistelix
Version: 0.31-1
Severity: grave
Tags: security
User: team at security.debian.org
Usertags: ldpath


During a review of the Debian archive, I've found your package to
contain a script that can be abused by an attacker to execute arbitrary

The vulnerability is introduced by an insecure change to
LD_LIBRARY_PATH, and environment variable used by ld.so(8) to look for
libraries on a directory other than the standard paths.

Vulnerable code follows:

/usr/bin/mistelix line 8:
export LD_LIBRARY_PATH=$libdir/mistelix/:$LD_LIBRARY_PATH

When there's an empty item on the colon-separated list of
LD_LIBRARY_PATH, ld.so treats it as '.' (i.e. CWD/$PWD.)
If the given script is executed from a directory where a potential,
local, attacker can write files to, there's a chance to exploit this

This vulnerability has been assigned the CVE id CVE-2010-3365. Please make sure
you mention it when forwarding this report to upstream and when fixing
this bug (everywhere: upstream and here at Debian.)

[0] http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2010-3365
[1] http://security-tracker.debian.org/tracker/CVE-2010-3365

Raphael Geissert

More information about the Ubuntu-mono mailing list