[ubuntu-mono] [Bug 536925] Re: gnome-keyring-sharp uses deprecated socket interface; apps cannot use keyring

directhex directhex at apebox.org
Fri Mar 19 13:06:17 GMT 2010


Yeah, that's the fix. I spoke briefly with Gonzalo Paniagua Javier on
IRC, the original author of g-k-s, who implied he had no immediate plans
to rewrite the binding (I guess his schedule is more likely to be tied
to openSUSE 11.3 than our rather more urgent Lucid release). So unless
someone else steps up within the next few weeks, this regression will
stand for Lucid.

It's made more complex because it seems the g-k-s API bears little
relationship with what GAPI produces from the C source, so either every
app needs to be ported to a brand new API, or significant time needs to
be spent doing the binding by hand rather than via tools like GAPI.

-- 
gnome-keyring-sharp uses deprecated socket interface; apps cannot use keyring
https://bugs.launchpad.net/bugs/536925
You received this bug notification because you are a member of MOTU Mono
Team, which is subscribed to f-spot in ubuntu.



More information about the Ubuntu-mono mailing list