[ubuntu-mono] [Bug 529974] [NEW] [FFe] Sync banshee 1.5.4-1 (universe) from Debian unstable (main)

Hew McLachlan hew.mclachlan at gmail.com
Mon Mar 1 11:32:27 GMT 2010


Public bug reported:

Binary package hint: banshee

Banshee 1.5.3 (currently in Ubuntu) is 1.6.0 beta 3, 1.5.4 is beta 4.
While there are a number of new features and enhancements with this
release, the main reason for including this in Lucid should be for the
bugfixes. This supports the Lucid goal of being a stable (LTS) release.

Testing:

I tested with Debian built binaries (amd64), upgrading from 1.5.3-1. Did
general testing of: playback, media keys, edit tags, playlists, sorting,
browsing, play queue, Last.fm, video. Everything seems to work. I tested
for an hour so far, and will continue to use it daily.

I had crashing/freezing problems with 1.5.3-1, which I have not
experienced so far with 1.5.4-1. While I haven't done enough testing to
indicate the problem is resolved, it seems that at least there are no
additional regressions.

Dependencies:

libtaglib2.0-cil got a version bump to 2.0.3.6+dfsg-1 in Debian, so I
tested with this version.

Banshee NEWS (upstream changelog):

http://download.banshee-
project.org/banshee/stable/1.5.4/banshee-1-1.5.4.news

Debian changelog:

 banshee  (1.5.4-1) unstable; urgency=low

   * New upstream release (Closes: #571734)
     + New features:
       - Opt-In Usage Data Collection
       - Default Equalizer Presets
       - Extensible Shuffle Modes
     + Enhancements:
       - Wikipedia context pane extension enabled by default
       - Add support for Nokia N900 phones
       - Add tooltip to playback error column
       - On close Internet Archive item, return to Search
       - Notify user if trying to sync missing file to DAP
       - Popup explanation of manual playlist ordering when appropriate
       - Simplify the default set of columns in Podcasts
       - Enable 'Delete From Drive' action in File System Queue
       - Coverart for unicode artist/albums now supported
       - Dropped glade-sharp dep; GNOME 3.0 ready
       - Add columns showing track sample rate and bits per sample
       - Option to sort an artist's albums by year, not title
       - If starting Banshee hidden (--hide), up to half a second of
         startup time is saved
     + Notable bug fixes:
       - Enable LibraryWatcher only for Music and Video libraries
       - Do better job preserving IsCompilation metadata
       - Store some PlayQueue settings in the db (not GConf)
       - Update to Last.fm's API change for scrobbling/recs
       - Bring back static FileNamePattern API used by some scripts
       - Fix several memory leaks
     + Other bugs fixed:
       - Fix segfault with Cairo when playing a song without album art (LP: #523913)
       - Follow symlinks when scanning the library (LP: #406667)
       - Fix issue importing mp3s with non-ASCII ID3 tags (LP: #364562)
   * debian/control:
     + Bump libtaglib-cil-dev version requirement to 2.0.3.5
     + Drop libglade2.0-cil-dev and libgnome2.0-cil-dev build-dep
     + Add libwebkit-cil-dev to build-deps
   * debian/rules:
     + Reorder configure flags to match upstream's ./configure --help listing
     + Add --enable-webkit since it is now enabled by default
   * debian/patches/01_monodoc-fix-enable.patch,
     debian/patches/series:
     + Dropped, applied upstream

 -- Chow Loong Jin <hyperair at ubuntu.com>  Sun, 28 Feb 2010 01:14:01
+0800

** Affects: banshee (Ubuntu)
     Importance: Undecided
         Status: New


** Tags: upgrade

-- 
[FFe] Sync banshee 1.5.4-1 (universe) from Debian unstable (main)
https://bugs.launchpad.net/bugs/529974
You received this bug notification because you are a member of MOTU Mono
Team, which is subscribed to banshee in ubuntu.



More information about the Ubuntu-mono mailing list