[ubuntu-mono] [Bug 630941] Re: Banshee crashes during sync

John Emhoff john at timeburger.com
Sat Dec 18 17:21:39 UTC 2010


Okay, so I tried again with banshee --debug with the intent of uploading
the output here, but for whatever reason the sync seems to have mostly
worked. 23 out of 605 songs failed with the message below. One of the
lines claims that all storage is full or corrupt, but this seems
unlikely considering the device says it has >6GB free and the 23
failures were not the last 23 songs to be sync'd.

Caught an exception - Mtp.LibMtpException: PTP Layer error 02ff:
get_storage_freespace(): could not get storage info. (in `')

Mtp.LibMtpException: (Look this up in ptp.h for an explanation.) (in `')

Mtp.LibMtpException: check_if_file_fits(): error checking free storage.
(in `')

Mtp.LibMtpException: get_writeable_storageid(): all device storage is
full or corrupt. (in `')

Mtp.LibMtpException: PTP Layer error 02ff: send_file_object_info():
Could not send object info. (in `')

Mtp.LibMtpException: (Look this up in ptp.h for an explanation.) (in `')

Mtp.LibMtpException: LIBMTP_Send_Track_From_File_Descriptor(): subcall to LIBMTP_Send_File_From_File_Descriptor failed. (in `Mtp')
  at Mtp.LibMtpException.CheckErrorStack (Mtp.MtpDeviceHandle handle) [0x00000] in <filename unknown>:0 
  at Mtp.Track.SendTrack (Mtp.MtpDeviceHandle handle, System.String path, Mtp.TrackStruct& metadata, Mtp.ProgressFunction callback, IntPtr data) [0x00000] in <filename unknown>:0 
  at Mtp.MtpDevice.UploadTrack (System.String path, Mtp.Track track, Mtp.Folder folder, Mtp.ProgressFunction callback) [0x00000] in <filename unknown>:0 
  at Banshee.Dap.Mtp.MtpSource.AddTrackToDevice (Banshee.Collection.Database.DatabaseTrackInfo track, Hyena.SafeUri fromUri) [0x00000] in <filename unknown>:0 
  at Banshee.Dap.DapSource.AttemptToAddTrackToDevice (Banshee.Collection.Database.DatabaseTrackInfo track, Hyena.SafeUri fromUri) [0x00000] in <filename unknown>:0 
  at Banshee.Dap.DapSource.AddTrackAndIncrementCount (Banshee.Collection.Database.DatabaseTrackInfo track) [0x00000] in <filename unknown>:0 
  at Banshee.Sources.PrimarySource.AddTrackList (System.Object cached_list) [0x00000] in <filename unknown>:0 
[1 Warn  12:11:38.310] Forcefully breaking out of RCS loop b/c change in total_width less than 1.0

-- 
You received this bug notification because you are a member of Ubuntu
CLI/Mono Uploaders, which is subscribed to banshee in ubuntu.
https://bugs.launchpad.net/bugs/630941

Title:
  Banshee crashes during sync

Status in “banshee” package in Ubuntu:
  Incomplete

Bug description:
  Binary package hint: banshee

Banshee segfaults when it tries to sync songs to my MTP device. The console output is:

$ banshee
[Info  11:49:12.981] Running Banshee 1.6.1: [Ubuntu 10.04 LTS (linux-gnu, x86_64) @ 2010-06-18 18:47:49 UTC]
[Info  11:49:13.785] All services are started 0.650639
[Info  11:49:14.464] nereid Client Started
Device 0 (VID=0781 and PID=74c2) is a SanDisk Sansa Fuze v2.
[Info  11:49:38.185] Uncached artwork size 170 requested
Segmentation fault

$ lsb_release -rd
Description:	Ubuntu 10.04.1 LTS
Release:	10.04

$ apt-cache policy banshee
banshee:
  Installed: 1.6.1-1~lucid1
  Candidate: 1.6.1-1~lucid1
  Version table:
 *** 1.6.1-1~lucid1 0
        500 http://ubuntu.media.mit.edu/ubuntu/ lucid-updates/universe Packages
        100 /var/lib/dpkg/status
     1.6.0-1 0
        500 http://ubuntu.media.mit.edu/ubuntu/ lucid/universe Packages





More information about the Ubuntu-mono mailing list