[ubuntu-mono] [Bug 508896] Re: Search for suitable plugin dialog useless

Matthew Exon 508896 at bugs.launchpad.net
Thu Aug 19 20:27:08 BST 2010


I'm on 10.4 now.  I've just tried Banshee a few times, and out of a
dozen or so tries I did see this behaviour one time.  Specifically:

* Arrange a playlist with one track that's not playable followed by two that are.
* Play the first track.
* Up comes a "search for codec" dialog box, and the second track plays
* Click "cancel".
* The second track is skipped, the third track plays.

What should happen is either the dialog box should stop it skipping to
the second track, or clicking cancel should do nothing.  Take your pick.

However, the more common case is:

It still fails to find a codec for WMV.  Which is bad, I'm a normal user
and don't care about codec licensing, I just want it to work.  But
anyway.  If I then try to play another WMV file it comes up with the
exact same dialog.  It doesn't remember that it tried and failed to find
that codec not 10 seconds ago.  Surprise surprise, I have an entire
album of WMV tracks and it makes me click through all of them one by
one.

And then it eventually gets to a track it can play, starts playing it,
and throws an unhandled exception.  But it remains on screen as a blank
zombie (still playing) and I have to forcefully kill it.  This mostly
happens instead of the "misbehaving cancel button" behaviour, and
sometimes you get a fun combination of both.

Finally, the "search for codec" dialog box still doesn't say which file
it's trying to play.  No matter what bugs exist in the rest of the
program, it definitely should.

-- 
Search for suitable plugin dialog useless
https://bugs.launchpad.net/bugs/508896
You received this bug notification because you are a member of Ubuntu
CLI/Mono Uploaders, which is subscribed to banshee in ubuntu.

Status in “banshee” package in Ubuntu: Incomplete

Bug description:
Binary package hint: gnome-media

I play my music with banshee, and it plays everything fine.  But every once in a while Ubuntu brings up a dialog box titled "Search for suitable plugin?", which claims that it can't play something.  If I try to search for a plugin, it has never yet been able to find anything.

What's really annoying is that if I click "cancel", Banshee skips the currently playing track.  Apparently the dialog box is too stupid to realise that the media player might have moved on since it wasted all that time searching for a non-existent plugin.

The other really frustrating thing about this dialog is that it doesn't provide any information about which file it's talking about.  It just says "this file", as if I manually clicked on the track.

And finally, when it fails to find a plugin to play the file, it doesn't record that fact anywhere and goes through the same sequence the next time it hits a file it doesn't understand.

I have no idea which package this bug belongs to.  It's not banshee, since I can quit banshee entirely and the dialog box doesn't go away.  It must be somewhere down in the tangled mess that is the Gnome multimedia system.

ProblemType: Bug
Architecture: i386
Date: Sun Jan 17 20:53:33 2010
DistroRelease: Ubuntu 9.10
Package: gnome-media 2.28.1-0ubuntu1
ProcEnviron:
 LANGUAGE=en_GB.UTF-8
 PATH=(custom, user)
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-17.54-generic
SourcePackage: gnome-media
Uname: Linux 2.6.31-17-generic i686





More information about the Ubuntu-mono mailing list