[ubuntu-mono] [Bug 586174] Re: Banshee corrupts certain music files

Artem Yakimenko 586174 at bugs.launchpad.net
Sun Aug 1 11:21:42 BST 2010

Can't yet replicate the bug, using "write metadata to files" both checked and unchecked.
But, I noticed there is a slight hiccup in playback when banshee writes the lyrics metadata after downloading them.
The audio got corrupted in the same exact place the last time, I don't know if this is helpful to you or not though.

For now I'll try to replicate the bug. As soon as that happens, I'll upload the files here.
Thanks for the quick answer.

Banshee corrupts certain music files
You received this bug notification because you are a member of Ubuntu
CLI/Mono Uploaders, which is subscribed to banshee in ubuntu.

Status in Banshee Music Player: New
Status in “banshee” package in Ubuntu: Confirmed
Status in “banshee-community-extensions” package in Ubuntu: Fix Released
Status in “banshee” source package in Lucid: New
Status in “banshee-community-extensions” source package in Lucid: Fix Released

Bug description:
Binary package hint: banshee

I purchased the album Lungs by Florence + the Machine from AmazonMP3.  The first time I downloaded it, I tried pyMazon.  It worked well, but as I started listening to the album in Banshee, I noticed some noise distortion after I listened to a song or two (sort of like squeeks, listen to attached mp3).  I quit Banshee and tried to listen to some of the songs in Totem.  The ones that had squeeked in Banshee, also squeeked in Totem, but others that I hadn't played using Banshee worked fine.  I thought maybe a file or two had been corrupted during download, so I re-opened Banshee and started playing the rest of the album.  Low and behold, some of the songs that had just played fine in Totem now had squeeks in Banshee.  When I quit Banshee and opened the same song in Totem, it now had the squeeks there also.

Now I started thinking maybe I had *somehow* missed the squeeks the first time listening in Totem and that the entire album had been corrupted somehow during download with pyMazon.  Unfortunately, I hadn't had a chance to make a back-up of the files and now they ALL had squeeks in them.  Forunately, I got the AmazonMP3 store to re-open the download for me.  I deleted the original (now corrupted) album.  This time I downloaded using the actual AmazonMP3 installer (for Windows) via Wine (since I can't get AmazonMP3's native downloader to work with Lucid).

After re-downloading the album, I made a back-up of the files right away.  I started by opening a bunch of the songs individually in Totem and Rhythmbox.  They had no squeeks, so I chalked up my problem to a corrupted download from pyMazon.  However, today I wanted to listen to the album again, so again I opened Banshee.  The first song played fine.  The second song (one which I'm confident I had checked in Rhythmbox and Totem just a few days ago) started squeeking.  I quit Banshee and opened up the file in Totem, and it squeeked there too!!

I then ran md5sums on the original and the back-up of the song that squeeks and a song I'm positive I haven't played yet in Banshee ("09 - Cosmic Love.mp3" is the song that squeeks):

jonathan at jonathan-laptop:~/Music/Amazon MP3/Florence + The Machine/Lungs$ md5sum "09 - Cosmic Love.mp3"
261ab6c0b58811a41706001c8874f00c  09 - Cosmic Love.mp3

jonathan at jonathan-laptop:~/Downloads/Florence + The Machine/Lungs$ md5sum "09 - Cosmic Love.mp3"
00da0f56c209d65ec25fe2397c088a53  09 - Cosmic Love.mp3

jonathan at jonathan-laptop:~/Music/Amazon MP3/Florence + The Machine/Lungs$ md5sum "12 - Blinding.mp3"
9280f68424d5d132830b559041ed8ca3  12 - Blinding.mp3

jonathan at jonathan-laptop:~/Downloads/Florence + The Machine/Lungs$ md5sum "12 - Blinding.mp3"
9280f68424d5d132830b559041ed8ca3  12 - Blinding.mp3

What the hell?

If you want to hear it, listen to the attached excerpts.

I'm using the default Banshee 1.6.0-1 packaged with Ubuntu 10.04 64-bit with plugins: application indicator, lyrics, ubuntu one music store, wikipedia, audio cd, audiobooks, file system preview, internet radio, play queue, podcasts, ipod support, karma support, mass storage media player support, mtp media player support, internet archive, last.fm, bookmarks, bpm, cover art, daap, importers for amarok etc, library watcher, multimedia keys

I also have the boxes checked (in Edit->Preferences): Write Metadata to files, Write ratings and play counts to files.  Perhaps the problem is related to those 2 boxes?

I also think it may have something to do with the "+" symbol in either the Artist ID3 tag or the file path.  I have played other music in Banshee in the last couple of days and this seems to be the only album affected that I've found.

Regardless, I definitely think this is a major bug.  Please let me know what more information I can provide.  My Banshee application also intermittently starts to freeze/hang occasionally.  I think it was actually doing that when I was playing one of the songs that ended up getting squeeks in it earlier.

TEST CASE (for banshee-community-extensions lucid SRU):
1. Backup a music file (it should not contain lyrics in it, verify with id3v2 -l)
2. Start Banshee (with lyrics extension enabled)
3. Turn off the "Write metadata to files" option.
4. Play the music file, and view the lyrics to make sure it is loaded.
5. Check that the music file is unchanged (lyrics should still not be present using id3v2 -l)

PATCH: http://gitorious.org/banshee-community-extensions/banshee-community-extensions/commit/f12d70a1b2a3a0a380ecabfcf7a3b15fe0c989ae (included in upstream sources already).

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: banshee 1.6.0-1
ProcVersionSignature: Ubuntu 2.6.32-22.33-generic
Uname: Linux 2.6.32-22-generic x86_64
Architecture: amd64
Date: Wed May 26 20:09:25 2010
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Release Candidate amd64 (20100419.1)
SourcePackage: banshee

More information about the Ubuntu-mono mailing list