[ubuntu-mono] [Bug 403135] Re: Notification area icon wrongly rendered/uses bg_color as a background (multiple apps)

Ricardo Pérez López ricpelo at gmail.com
Fri Apr 9 22:27:46 BST 2010


JDownloader (http://jdownloader.org) and FreeRapid Downloader
(http://wordrider.net/freerapid) are affected by this bug, too. Their
tray icons have an ugly white background color when using Ambiance theme
(dark background panel).

-- 
Notification area icon wrongly rendered/uses bg_color as a background (multiple apps)
https://bugs.launchpad.net/bugs/403135
You received this bug notification because you are a member of Ubuntu
CLI/Mono Uploaders, which is subscribed to banshee in ubuntu.

Status in AllTray: Fix Released
Status in aMSN: Confirmed
Status in Banshee Music Player: New
Status in Beagle Desktop Search: Unknown
Status in a fast and powerful GTK+ based mail client: Unknown
Status in FileZilla FTP Client: Confirmed
Status in firestarter: New
Status in gmusicbrowser with now-playing support: New
Status in Mail Notification: New
Status in Pidgin: Fix Released
Status in Quod Libet is a GTK+-based audio player written in Python.: New
Status in Wine: Confirmed
Status in “alltray” package in Ubuntu: Confirmed
Status in “amsn” package in Ubuntu: Confirmed
Status in “azureus” package in Ubuntu: Confirmed
Status in “banshee” package in Ubuntu: Triaged
Status in “checkgmail” package in Ubuntu: New
Status in “claws-mail” package in Ubuntu: Confirmed
Status in “gnome-panel” package in Ubuntu: Confirmed
Status in “gxneur” package in Ubuntu: Confirmed
Status in “liferea” package in Ubuntu: New
Status in “openoffice.org” package in Ubuntu: Confirmed
Status in “pidgin” package in Ubuntu: Confirmed
Status in “vlc” package in Ubuntu: Confirmed
Status in “wine” package in Ubuntu: New

Bug description:
The following bug may possibly depend on my setup, if so just tell me how to check this. I am using banshee 1.4.3-5 (in ubuntu karmic) and its notification area icon has a black background, unlike other applets that have a transparent background.

I attach a screenshot.

This bug is noticed when:
a) Themes set a background image in the gtkrc
b) If users set a custom image for the panel from Panel Properties > Background > Background Image

***This bug affects all themes , but has become easier to notice since the default light-themes use a background image.***

Also , see , comment #99 , might be a regression in gnome-panel since Karmic release.







More information about the Ubuntu-mono mailing list