[ubuntu-mono] [Bug 139050] Re: dbus error: F-Spot not launching on a fresh install of Kubuntu Gutsy

e 0x0065 at gmail.com
Sun Sep 23 09:28:16 BST 2007


This error occurs on my gentoo system with dbus running as a service and all other apps using dbus without reporting any problem...
...probably an f-spot problem.

erik at 0x0065 ~ $ f-spot
System.ApplicationException: F-Spot cannot find the Dbus session bus.  Make sure dbus is configured properly or start a new session for f-spot using "dbus-launch f-spot" ---> System.Exception: Unable to open the session message bus. ---> System.ArgumentNullException: Argument cannot be null.
Parameter name: address
  at NDesk.DBus.Bus.Open (System.String address) [0x00000] 
  at NDesk.DBus.Bus.get_Session () [0x00000] --- End of inner exception stack trace ---

  at NDesk.DBus.Bus.get_Session () [0x00000] 
  at NDesk.DBus.BusG.Init () [0x00000] 
  at FSpot.Driver.Main (System.String[] args) [0x00000] --- End of inner exception stack trace ---

  at FSpot.Driver.Main (System.String[] args) [0x00000]

erik at 0x0065 ~ $ su          
Password: 
0x0065 erik # /etc/init.d/dbus start
 * WARNING:  dbus has already been started.
0x0065 erik # ps -A | grep dbus
 5227 ?        00:00:00 dbus-daemon
 5464 ?        00:00:00 dbus-launch
 5465 ?        00:00:00 dbus-daemon
0x0065 erik #  exit
erik at 0x0065 ~ $ f-spot
System.ApplicationException: F-Spot cannot find the Dbus session bus.  Make sure dbus is configured properly or start a new session for f-spot using "dbus-launch f-spot" ---> System.Exception: Unable to open the session message bus. ---> System.ArgumentNullException: Argument cannot be null.
Parameter name: address
  at NDesk.DBus.Bus.Open (System.String address) [0x00000] 
  at NDesk.DBus.Bus.get_Session () [0x00000] --- End of inner exception stack trace ---

  at NDesk.DBus.Bus.get_Session () [0x00000] 
  at NDesk.DBus.BusG.Init () [0x00000] 
  at FSpot.Driver.Main (System.String[] args) [0x00000] --- End of inner exception stack trace ---

  at FSpot.Driver.Main (System.String[] args) [0x00000]

erik at 0x0065 ~ $ dbus-launch f-spot
Initializing Mono.Addins
Starting new FSpot server

...again, nothing else is complaining...


** Changed in: f-spot (Ubuntu)
       Status: Invalid => Confirmed

-- 
dbus error: F-Spot not launching on a fresh install of Kubuntu Gutsy
https://bugs.launchpad.net/bugs/139050
You received this bug notification because you are a member of MOTU Mono
Team, which is a bug contact for f-spot in ubuntu.



More information about the Ubuntu-mono mailing list