[ubuntu-mono] [Bug 121280] Could not calculate the upgrade

ursli dieter at changes.ch
Fri Jun 29 06:12:43 BST 2007


You have been subscribed to a public bug:

Binary package hint: update-manager

apt.log:

Installing openoffice.org-core as dep of openoffice.org-gnome
Installing openoffice.org-common as dep of openoffice.org-core
Installing openoffice.org-style-human as dep of openoffice.org-common
Installing openoffice.org-style-andromeda as dep of openoffice.org-common
Installing libwps-0.1-1 as dep of openoffice.org-writer
Installing python-uno as dep of openoffice.org-writer
Installing openoffice.org-draw as dep of openoffice.org-impress
Installing dcraw as dep of ubuntu-desktop
Setting NOT as auto-installed because its a direct dep of a package in section metapackages
Installing libdatrie0 as dep of libpango1.0-0
Installing libthai0 as dep of libpango1.0-0
Installing libthai-data as dep of libthai0
Starting
Starting 2
Investigating openoffice.org-style-andromeda
Package openoffice.org-style-andromeda has broken dep on openoffice.org-style-default
  Considering openoffice.org-style-default 0 as a solution to openoffice.org-style-andromeda 12
  Added openoffice.org-style-default to the remove list
  Considering openoffice.org-style-default 0 as a solution to openoffice.org-style-andromeda 12
  Considering openoffice.org-style-default 0 as a solution to openoffice.org-style-andromeda 12
  Considering openoffice.org-style-default 0 as a solution to openoffice.org-style-andromeda 12
  Fixing openoffice.org-style-andromeda via remove of openoffice.org-style-default
Done
ERROR:root:Unauthenticated packages found: 'dcraw libdatrie0 libpango1.0-0 libthai-data libthai0 libwps-0.1-1 openoffice.org openoffice.org-base openoffice.org-calc openoffice.org-common openoffice.org-core openoffice.org-draw openoffice.org-evolution openoffice.org-filter-binfilter openoffice.org-gnome openoffice.org-gtk openoffice.org-help-en-us openoffice.org-impress openoffice.org-l10n-en-gb openoffice.org-l10n-en-za openoffice.org-math openoffice.org-style-andromeda openoffice.org-style-crystal openoffice.org-style-human openoffice.org-style-industrial openoffice.org-writer python-uno ubuntu-desktop'
Installing openoffice.org-core as dep of openoffice.org-gnome
Installing openoffice.org-common as dep of openoffice.org-core
Installing openoffice.org-style-human as dep of openoffice.org-common
Installing openoffice.org-style-andromeda as dep of openoffice.org-common
Installing libwps-0.1-1 as dep of openoffice.org-writer
Installing python-uno as dep of openoffice.org-writer
Installing openoffice.org-draw as dep of openoffice.org-impress
Installing dcraw as dep of ubuntu-desktop
Setting NOT as auto-installed because its a direct dep of a package in section metapackages
Installing libdatrie0 as dep of libpango1.0-0
Installing libthai0 as dep of libpango1.0-0
Installing libthai-data as dep of libthai0
Starting
Starting 2
Investigating openoffice.org-style-andromeda
Package openoffice.org-style-andromeda has broken dep on openoffice.org-style-default
  Considering openoffice.org-style-default 0 as a solution to openoffice.org-style-andromeda 12
  Added openoffice.org-style-default to the remove list
  Considering openoffice.org-style-default 0 as a solution to openoffice.org-style-andromeda 12
  Considering openoffice.org-style-default 0 as a solution to openoffice.org-style-andromeda 12
  Considering openoffice.org-style-default 0 as a solution to openoffice.org-style-andromeda 12
  Fixing openoffice.org-style-andromeda via remove of openoffice.org-style-default
Done
ERROR:root:Unauthenticated packages found: 'dcraw libdatrie0 libpango1.0-0 libthai-data libthai0 libwps-0.1-1 openoffice.org openoffice.org-base openoffice.org-calc openoffice.org-common openoffice.org-core openoffice.org-draw openoffice.org-evolution openoffice.org-filter-binfilter openoffice.org-gnome openoffice.org-gtk openoffice.org-help-en-us openoffice.org-impress openoffice.org-l10n-en-gb openoffice.org-l10n-en-za openoffice.org-math openoffice.org-style-andromeda openoffice.org-style-crystal openoffice.org-style-human openoffice.org-style-industrial openoffice.org-writer python-uno ubuntu-desktop'
Installing libwxbase2.6-0 as dep of libwxgtk2.6-0
Installing libntfs-3g1 as dep of ntfs-3g
Installing libmono-cecil0.5-cil as dep of monodevelop
Starting
Starting 2
Investigating libwxbase2.6-0
Package libwxbase2.6-0 has broken dep on libc6
Investigating libwxgtk2.6-0
Package libwxgtk2.6-0 has broken dep on libc6
Investigating mono-xsp-base
Package mono-xsp-base has broken dep on libc6
Package mono-xsp-base has broken dep on libc6.1
Package mono-xsp-base has broken dep on libc0.1
  Or group remove for mono-xsp-base
Investigating menu
Package menu has broken dep on libgcc1
Investigating mono-xsp
Package mono-xsp has broken dep on mono-xsp-base
  Considering mono-xsp-base 2 as a solution to mono-xsp 1
  Removing mono-xsp rather than change mono-xsp-base
Investigating boinc-client
Package boinc-client has broken dep on libgcc1
Investigating boinc-manager
Package boinc-manager has broken dep on libgcc1
Investigating gstreamer0.10-plugins-ugly
Package gstreamer0.10-plugins-ugly has broken dep on libc6
Investigating gstreamer0.10-ffmpeg
Package gstreamer0.10-ffmpeg has broken dep on libc6
Investigating libmono-cecil0.5-cil
Package libmono-cecil0.5-cil has broken dep on libmono-cecil0.4-cil
  Considering libmono-cecil0.4-cil 0 as a solution to libmono-cecil0.5-cil 0
  Holding Back libmono-cecil0.5-cil rather than change libmono-cecil0.4-cil
Investigating kvpnc
Package kvpnc has broken dep on kdelibs4c2a
Investigating monodoc-http
Package monodoc-http has broken dep on mono-xsp
  Considering mono-xsp 1 as a solution to monodoc-http 0
Package monodoc-http has broken dep on mono-apache-server
  Considering mono-apache-server 1 as a solution to monodoc-http 0
  Or group remove for monodoc-http
Investigating gtk2-engines-cleanice
Package gtk2-engines-cleanice has broken dep on libc6
Investigating gtk2-engines-wonderland
Package gtk2-engines-wonderland has broken dep on libc6
Investigating monodevelop
Package monodevelop has broken dep on libmetacity0
 Try to Re-Instate libwxbase2.6-0
 Try to Re-Instate libwxgtk2.6-0
 Try to Re-Instate menu
 Try to Re-Instate boinc-client
 Try to Re-Instate boinc-manager
 Try to Re-Instate gstreamer0.10-plugins-ugly
 Try to Re-Instate gstreamer0.10-ffmpeg
 Try to Re-Instate kvpnc
 Try to Re-Instate gtk2-engines-cleanice
 Try to Re-Instate gtk2-engines-wonderland
 Try to Re-Instate monodevelop
Done
MarkUpgrade() called on a non-upgrable pkg: 'ubuntu-desktop'
MarkUpgrade() called on a non-upgrable pkg: 'kubuntu-desktop'
ERROR:root:got an error from dpkg for pkg: 'mono-xsp': 'subprocess pre-removal script returned error exit status 2
'
ERROR:root:got an error from dpkg for pkg: 'mono-xsp': 'subprocess pre-removal script returned error exit status 2
'
ERROR:root:SystemError from cache.commit(): installArchives() failed
Installing libc6 as dep of beryl-core
Installing libxdamage1 as dep of beryl-core
Installing xserver-xorg-core as dep of xserver-xorg
Installing libgcc1 as dep of xserver-xorg-core
Installing gcc-4.2-base as dep of libgcc1
Installing kdelibs4c2a as dep of kpdf
Installing libart-2.0-2 as dep of kdelibs4c2a
Installing libgnutls13 as dep of kdelibs4c2a
Installing libopencdk8 as dep of libgnutls13
Installing libjasper1 as dep of kdelibs4c2a
Installing libstdc++6 as dep of kdelibs4c2a
Installing kdelibs-data as dep of kdelibs4c2a
Installing libpango1.0-0 as dep of f-spot
Installing libpango1.0-common as dep of libpango1.0-0
Installing libglib2.0-0 as dep of libpango1.0-0
Installing libgphoto2-2 as dep of f-spot
Installing libgphoto2-port0 as dep of libgphoto2-2
Installing libdevmapper1.02.1 as dep of dmsetup
Installing libselinux1 as dep of libdevmapper1.02.1
Installing libsepol1 as dep of libselinux1
Installing volumeid as dep of udev
Installing ghostscript-x as dep of gs-esp-x
Installing ghostscript as dep of ghostscript-x
Installing libgs8 as dep of ghostscript
Installing libsdl1.2debian-alsa as dep of libsdl1.2debian
Installing libgnomekbd-common as dep of libgnomekbd1
Installing libcurl4-openssl as dep of boinc-manager
Installing libssl0.9.8 as dep of libcurl4-openssl
Installing libwxbase2.6-0 as dep of boinc-manager
Installing libwxgtk2.6-0 as dep of boinc-manager
Installing libgmime2.2-cil as dep of tomboy
Installing libbz2-1.0 as dep of bzip2
Installing libecal1.2-7 as dep of evolution-webcal
Installing libedataserver1.2-9 as dep of libecal1.2-7
Installing libnspr4-0d as dep of libedataserver1.2-9
Installing libespeak1 as dep of espeak
Installing espeak-data as dep of libespeak1
Installing libebook1.2-9 as dep of ekiga
Installing libcamel1.2-10 as dep of libebook1.2-9
Installing libnss3-0d as dep of libcamel1.2-10
Installing libopal-2.2.0 as dep of ekiga
Installing libpt-1.10.0 as dep of libopal-2.2.0
Installing libmono-corlib2.0-cil as dep of libmono2.0-cil
Installing mono-jit as dep of libmono-corlib2.0-cil
Installing mono-common as dep of mono-jit
Installing libmono-system2.0-cil as dep of libmono2.0-cil
Installing libhunspell-1.1-0 as dep of libenchant1c2a
Installing libgnomevfs2-common as dep of libgnomevfs2-0
Installing networkstatus as dep of knetworkmanager
Installing kmplayer-base as dep of kmplayer-konq-plugins
Installing libscim8c2a as dep of scim-modules-table
Installing libmetacity0 as dep of metacity
Installing metacity-common as dep of libmetacity0
Installing librsvg2-2 as dep of nautilus
Installing nautilus-data as dep of nautilus
Installing libbind9-30 as dep of bind9-host
Installing libdns32 as dep of libbind9-30
Installing libisc32 as dep of libdns32
Installing libisccfg30 as dep of libbind9-30
Installing libisccc30 as dep of libisccfg30
Installing liblwres30 as dep of bind9-host
Installing libgamin0 as dep of gamin
Installing language-pack-en as dep of language-pack-en-base
Installing linux-headers-2.6.22-6-generic as dep of linux-headers-generic
Installing linux-headers-2.6.22-6 as dep of linux-headers-2.6.22-6-generic
Installing libaspell15 as dep of aspell
Installing dhcp3-common as dep of dhcp3-client
Installing xserver-xorg-video-intel as dep of xserver-xorg-video-all
Installing xsane-common as dep of xsane
Installing libgimp2.0 as dep of xsane
Installing libgcj7-1 as dep of libgcj-bc
Installing libflac++5 as dep of libk3b2
Installing xdg-utils as dep of libdjvulibre15
Installing libgtk2.0-0 as dep of libwmf0.2-7
Installing libcurl4-gnutls as dep of vorbis-tools
Installing libiw29 as dep of wireless-tools
Installing samba-common as dep of smbclient
Installing libatspi1.0-0 as dep of brltty-x11
Installing brltty as dep of brltty-x11
Installing libgucharmap6 as dep of gucharmap
Installing kicker as dep of kcontrol
Installing libkonq4 as dep of kicker
Installing kdebase-data as dep of kicker
Installing libnotify1 as dep of zenity
Installing gnome-games-data as dep of gnome-games
Installing gdebi-core as dep of gdebi
Installing evolution as dep of evolution-exchange
Installing libedataserverui1.2-8 as dep of evolution
Installing libegroupwise1.2-13 as dep of evolution
Installing libexchange-storage1.2-3 as dep of evolution
Installing libgtkhtml3.14-19 as dep of evolution
Installing evolution-data-server as dep of evolution
Installing libedata-book1.2-2 as dep of evolution-data-server
Installing libedata-cal1.2-6 as dep of evolution-data-server
Installing evolution-data-server-common as dep of evolution-data-server
Installing libkdepim1a as dep of libkcal2b
Installing linux-image-2.6.22-6-generic as dep of linux-image-generic
Installing linux-ubuntu-modules-2.6.22-6-generic as dep of linux-image-generic
Installing libpoppler-qt1 as dep of kdegraphics-kfile-plugins
Installing libmusicbrainz4c2a as dep of rhythmbox
Installing libtotem-plparser7 as dep of rhythmbox
Installing libexiv2-0 as dep of gwenview
Installing python-gmenu as dep of gnome-menus
Installing libsnmp10 as dep of hpijs
Installing libsnmp-base as dep of libsnmp10
Installing libkmime2 as dep of kdepim-kio-plugins
Installing libqt4-core as dep of libqt4-qt3support
Installing libqt4-gui as dep of libqt4-qt3support
Installing libqt4-sql as dep of libqt4-qt3support
Installing libsqlite3-0 as dep of libqt4-sql
Installing language-pack-gnome-en as dep of language-pack-gnome-en-base
Installing capplets-data as dep of gnome-control-center
Installing libgnome-window-settings1 as dep of gnome-control-center
Installing libsasl2-2 as dep of libsasl2-modules
Installing libkcddb1 as dep of kdemultimedia-kio-plugins
Installing xvnc4viewer as dep of ubuntu-desktop
Setting NOT as auto-installed because its a direct dep of a package in section metapackages
new important dependency: pidgin
Installing pidgin as dep of ubuntu-desktop
Setting NOT as auto-installed because its a direct dep of a package in section metapackages
Installing pidgin-data as dep of pidgin
Installing libavahi-compat-howl0 as dep of pidgin
Installing libkleopatra1 as dep of kontact
Installing libkpimidentities1 as dep of kontact
Installing cupsys-client as dep of cupsys-bsd
Installing fontconfig-config as dep of libfontconfig1
Installing ksysguardd as dep of ksysguard
Installing python2.5 as dep of python2.5-dev
Installing python2.5-minimal as dep of python2.5
Installing cpp-4.1 as dep of gcc-4.1
Installing python-apport as dep of apport-qt
Installing python-problem-report as dep of python-apport
Installing libart2.0-cil as dep of libgnome2.0-cil
Installing libgnome-vfs2.0-cil as dep of libgnome2.0-cil
Installing libgtkhtml2.0-cil as dep of libgnome2.0-cil
Installing librsvg2.0-cil as dep of libgnome2.0-cil
Installing libruby1.8 as dep of ruby1.8
Installing libkexiv2-1 as dep of kipi-plugins
Installing libkpimexchange1 as dep of korganizer
Installing compiz-core as dep of compiz-plugins
Installing libgnome-speech7 as dep of gnome-orca
Installing python-orca-brlapi as dep of gnome-orca
Installing python-sip4 as dep of python-qt3
Installing libkdcraw0 as dep of digikam
Installing libkdcraw-runtime as dep of digikam
Installing libvte-common as dep of libvte9
Installing libmono-ldap2.0-cil as dep of lat
Installing libdb4.5 as dep of bogofilter-bdb
Installing libpcrecpp0 as dep of gnome-system-monitor
Installing libbonobo2-common as dep of libbonobo2-0
Installing libpoppler-glib1 as dep of evince
Installing libmagic1 as dep of file
Installing guidance-backends as dep of kde-guidance
Installing sexy-python as dep of gnome-app-install
Installing gimp-data as dep of gimp
Installing libgl1-mesa-glx as dep of libgl1-mesa-dri
Installing gnupg as dep of libgpgme11
Installing gnome-panel-data as dep of gnome-panel
Installing libntfs-3g2 as dep of ntfs-3g
Installing libgnomeprintui2.2-common as dep of libgnomeprintui2.2-0
Installing libgdl-1-common as dep of libgdl-1-0
Installing libmono-cecil0.5-cil as dep of monodevelop
Installing libxcb-shape0 as dep of libxine1
Installing libxcb1 as dep of libxcb-shape0
Installing libxcb-shm0 as dep of libxine1
Installing libxcb-xv0 as dep of libxine1
Starting
Starting 2
Investigating libgtk2.0-0
Package libgtk2.0-0 has broken dep on gtk2-engines-magicchicken
  Considering gtk2-engines-magicchicken 0 as a solution to libgtk2.0-0 880
  Added gtk2-engines-magicchicken to the remove list
  Fixing libgtk2.0-0 via remove of gtk2-engines-magicchicken
Investigating dbus
Package dbus has broken dep on dbus-1-utils
  Considering dbus-1-utils -1 as a solution to dbus 115
  Added dbus-1-utils to the remove list
  Fixing dbus via remove of dbus-1-utils
Investigating firefox
Package firefox has broken dep on libnss3
  Considering libnss3 0 as a solution to firefox 11
  Added libnss3 to the remove list
  Fixing firefox via remove of libnss3
Investigating libsasl2
Package libsasl2 has broken dep on libsasl2-2
  Considering libsasl2-2 55 as a solution to libsasl2 3
  Removing libsasl2 rather than change libsasl2-2
Investigating compiz-gnome
Package compiz-gnome has broken dep on compiz-gtk
  Considering compiz-gtk -1 as a solution to compiz-gnome 3
  Added compiz-gtk to the remove list
  Fixing compiz-gnome via remove of compiz-gtk
Investigating libpoppler-glib1
Package libpoppler-glib1 has broken dep on libpoppler1-glib
  Considering libpoppler1-glib -1 as a solution to libpoppler-glib1 3
  Added libpoppler1-glib to the remove list
  Fixing libpoppler-glib1 via remove of libpoppler1-glib
Investigating libk3b2
Package libk3b2 has broken dep on libflac++5
  Considering libflac++5 1 as a solution to libk3b2 2
  Holding Back libk3b2 rather than change libflac++5
Investigating k3b
Package k3b has broken dep on libk3b2
  Considering libk3b2 2 as a solution to k3b 1
  Holding Back k3b rather than change libk3b2
Investigating libpoppler-qt1
Package libpoppler-qt1 has broken dep on libpoppler1-qt
  Considering libpoppler1-qt -1 as a solution to libpoppler-qt1 1
  Added libpoppler1-qt to the remove list
  Fixing libpoppler-qt1 via remove of libpoppler1-qt
Investigating libcamel1.2-8
Package libcamel1.2-8 has broken dep on libnss3
  Considering libnss3 0 as a solution to libcamel1.2-8 0
  Removing libcamel1.2-8 rather than change libnss3
Investigating libmono-cecil0.5-cil
Package libmono-cecil0.5-cil has broken dep on libmono-cecil0.4-cil
  Considering libmono-cecil0.4-cil 0 as a solution to libmono-cecil0.5-cil 0
  Holding Back libmono-cecil0.5-cil rather than change libmono-cecil0.4-cil
Investigating digikam
Package digikam has broken dep on libkexiv2-0
  Considering libkexiv2-0 -1 as a solution to digikam 0
  Added libkexiv2-0 to the remove list
Package digikam has broken dep on libexiv2-0.12
  Considering libexiv2-0.12 2 as a solution to digikam 0
  Holding Back digikam rather than change libexiv2-0.12
  Fixing digikam via remove of libkexiv2-0
Investigating libgnome-speech7
Package libgnome-speech7 has broken dep on libgnome-speech3
  Considering libgnome-speech3 -1 as a solution to libgnome-speech7 0
  Added libgnome-speech3 to the remove list
  Fixing libgnome-speech7 via remove of libgnome-speech3
Investigating monodevelop
Package monodevelop has broken dep on libmono-cecil0.5-cil
  Considering libmono-cecil0.5-cil 0 as a solution to monodevelop 0
  Holding Back monodevelop rather than change libmono-cecil0.5-cil
 Try to Re-Instate libk3b2
 Try to Re-Instate k3b
 Try to Re-Instate digikam
Investigating digikam
Package digikam has broken dep on libkexiv2-0
  Considering libkexiv2-0 -1 as a solution to digikam 0
  Added libkexiv2-0 to the remove list
  Fixing digikam via keep of libkexiv2-0
 Try to Re-Instate monodevelop
Done
ERROR:root:got an error from dpkg for pkg: '/var/cache/apt/archives/mono-xsp_1.2.1-2.2ubuntu1_all.deb': 'subprocess pre-installation script returned error exit status 2
'
ERROR:root:got an error from dpkg for pkg: '/var/cache/apt/archives/mono-xsp_1.2.1-2.2ubuntu1_all.deb': 'subprocess pre-installation script returned error exit status 2
'
Traceback (most recent call last):
  File "/usr/share/apport/package_hook", line 15, in <module>
    import apport, apport.fileutils
ImportError: No module named apport
WARNING:root:no activity on terminal for 240 seconds (Preparing mono-xsp)
ERROR:root:got an error from dpkg for pkg: 'mono-xsp': 'package mono-xsp is already installed and configured
'
ERROR:root:got an error from dpkg for pkg: 'mono-xsp': 'package mono-xsp is already installed and configured
'
WARNING:root:no activity on terminal for 240 seconds (Installed brltty-x11)
ERROR:root:SystemError from cache.commit(): installArchives() failed
Installing libgtk2.0-0 as dep of gnome-keyring
Installing libgtk2.0-common as dep of libgtk2.0-0
Installing libuniconf4.3 as dep of wvdial
Installing libwvstreams4.3-base as dep of libuniconf4.3
Installing libwvstreams4.3-extras as dep of libuniconf4.3
Installing libflac++5 as dep of libk3b2
Installing libgda3-3 as dep of python-gnome2-extras
Installing libgda3-common as dep of libgda3-3
Installing libgdl-gnome-1-0 as dep of python-gnome2-extras
Installing libedataserver1.2-9 as dep of libexchange-storage1.2-3
Installing libkrb53 as dep of libexchange-storage1.2-3
Installing libkeyutils1 as dep of libkrb53
Installing python-gmenu as dep of gnome-menus
Installing libecal1.2-7 as dep of libedata-cal1.2-6
Installing ksysguardd as dep of ksysguard
Installing libwavpack1 as dep of gstreamer0.10-plugins-good
Installing libgtkhtml3.14-19 as dep of gtkhtml3.14
Installing libglib2.0-0 as dep of libwnck22
Installing libc6 as dep of libc6-i686
Installing compiz-core as dep of compiz-plugins
Installing volumeid as dep of udev
Installing python-orca-brlapi as dep of gnome-orca
Installing evolution-data-server-common as dep of evolution-data-server
Installing compiz-compcomm-plugins-main as dep of compiz
Installing libmono-cecil0.5-cil as dep of monodevelop
Installing libcompizconfig-backend-gconf as dep of compiz-gnome
Installing libcompizconfig0 as dep of libcompizconfig-backend-gconf
Starting
Starting 2
Investigating libk3b2
Package libk3b2 has broken dep on libflac++5
  Considering libflac++5 1 as a solution to libk3b2 2
  Holding Back libk3b2 rather than change libflac++5
Investigating libuniconf4.3
Package libuniconf4.3 has broken dep on libuniconf4.2
  Considering libuniconf4.2 -1 as a solution to libuniconf4.3 2
  Added libuniconf4.2 to the remove list
  Fixing libuniconf4.3 via remove of libuniconf4.2
Investigating k3b
Package k3b has broken dep on libk3b2
  Considering libk3b2 2 as a solution to k3b 1
  Holding Back k3b rather than change libk3b2
Investigating network-manager-gnome
Package network-manager-gnome has broken dep on network-manager
  Considering network-manager 1 as a solution to network-manager-gnome 0
  Removing network-manager-gnome rather than change network-manager
Investigating libmono-cecil0.5-cil
Package libmono-cecil0.5-cil has broken dep on libmono-cecil0.4-cil
  Considering libmono-cecil0.4-cil 0 as a solution to libmono-cecil0.5-cil 0
  Holding Back libmono-cecil0.5-cil rather than change libmono-cecil0.4-cil
Investigating digikam
Package digikam has broken dep on libkexiv2-0
  Considering libkexiv2-0 -1 as a solution to digikam 0
  Added libkexiv2-0 to the remove list
Package digikam has broken dep on libexiv2-0.12
  Considering libexiv2-0.12 1 as a solution to digikam 0
  Holding Back digikam rather than change libexiv2-0.12
  Fixing digikam via remove of libkexiv2-0
Investigating monodevelop
Package monodevelop has broken dep on libmono-cecil0.5-cil
  Considering libmono-cecil0.5-cil 0 as a solution to monodevelop 0
  Holding Back monodevelop rather than change libmono-cecil0.5-cil
 Try to Re-Instate libk3b2
 Try to Re-Instate k3b
 Try to Re-Instate digikam
Investigating digikam
Package digikam has broken dep on libkexiv2-0
  Considering libkexiv2-0 -1 as a solution to digikam 0
  Added libkexiv2-0 to the remove list
  Fixing digikam via keep of libkexiv2-0
 Try to Re-Instate monodevelop
Done
MarkUpgrade() called on a non-upgrable pkg: 'ubuntu-desktop'
MarkUpgrade() called on a non-upgrable pkg: 'kubuntu-desktop'
ERROR:root:gor error from PostInstallScript ./apt-autoinst-fixup.py ([Errno 2] No such file or directory: './apt-autoinst-fixup.py')
Installing libpango1.0-0 as dep of metacity
Installing libpango1.0-common as dep of libpango1.0-0
Installing libflac++5 as dep of libk3b2
Installing apt as dep of aptitude
Installing apt-utils as dep of python-apt
Installing libvte-common as dep of libvte9
Installing libcairomm-1.0-1 as dep of gnome-system-monitor
Installing libglibmm-2.4-1c2a as dep of gnome-system-monitor
Installing libgtkmm-2.4-1c2a as dep of gnome-system-monitor
Installing libgtop2-7 as dep of gnome-system-monitor
Installing libmono-cecil0.5-cil as dep of monodevelop
Starting
Starting 2
Investigating debtags
Package debtags has broken dep on libapt-pkg-libc6.4-6-3.53
  Considering apt 20 as a solution to debtags 3
  Removing debtags rather than change libapt-pkg-libc6.4-6-3.53
Investigating adept-manager
Package adept-manager has broken dep on libapt-pkg-libc6.4-6-3.53
  Considering apt 20 as a solution to adept-manager 2
  Removing adept-manager rather than change libapt-pkg-libc6.4-6-3.53
Investigating libk3b2
Package libk3b2 has broken dep on libflac++5
  Considering libflac++5 1 as a solution to libk3b2 2
  Holding Back libk3b2 rather than change libflac++5
Investigating adept-updater
Package adept-updater has broken dep on libapt-pkg-libc6.4-6-3.53
  Considering apt 20 as a solution to adept-updater 2
  Removing adept-updater rather than change libapt-pkg-libc6.4-6-3.53
Investigating adept
Package adept has broken dep on adept-manager
  Considering adept-manager 2 as a solution to adept 2
  Removing adept rather than change adept-manager
Investigating adept-installer
Package adept-installer has broken dep on libapt-pkg-libc6.4-6-3.53
  Considering apt 20 as a solution to adept-installer 1
  Removing adept-installer rather than change libapt-pkg-libc6.4-6-3.53
Investigating adept-batch
Package adept-batch has broken dep on libapt-pkg-libc6.4-6-3.53
  Considering apt 20 as a solution to adept-batch 1
  Removing adept-batch rather than change libapt-pkg-libc6.4-6-3.53
Investigating k3b
Package k3b has broken dep on libk3b2
  Considering libk3b2 2 as a solution to k3b 1
  Holding Back k3b rather than change libk3b2
Investigating language-selector-qt
Package language-selector-qt has broken dep on adept
  Considering adept 2 as a solution to language-selector-qt 1
  Removing language-selector-qt rather than change adept
Investigating adept-notifier
Package adept-notifier has broken dep on libapt-pkg-libc6.4-6-3.53
  Considering apt 20 as a solution to adept-notifier 1
  Removing adept-notifier rather than change libapt-pkg-libc6.4-6-3.53
Investigating kubuntu-desktop
Package kubuntu-desktop has broken dep on adept
  Considering adept 2 as a solution to kubuntu-desktop 0
  Removing kubuntu-desktop rather than change adept
Investigating libmono-cecil0.5-cil
Package libmono-cecil0.5-cil has broken dep on libmono-cecil0.4-cil
  Considering libmono-cecil0.4-cil 0 as a solution to libmono-cecil0.5-cil 0
  Holding Back libmono-cecil0.5-cil rather than change libmono-cecil0.4-cil
Investigating digikam
Package digikam has broken dep on libkexiv2-0
  Considering libkexiv2-0 -1 as a solution to digikam 0
  Added libkexiv2-0 to the remove list
Package digikam has broken dep on libexiv2-0.12
  Considering libexiv2-0.12 1 as a solution to digikam 0
  Holding Back digikam rather than change libexiv2-0.12
  Fixing digikam via remove of libkexiv2-0
Investigating monodevelop
Package monodevelop has broken dep on libmono-cecil0.5-cil
  Considering libmono-cecil0.5-cil 0 as a solution to monodevelop 0
  Holding Back monodevelop rather than change libmono-cecil0.5-cil
Investigating adept-common
Package adept-common has broken dep on debtags
  Considering debtags 3 as a solution to adept-common 4
  Added debtags to the remove list
  Fixing adept-common via keep of debtags
Investigating debtags
Package debtags has broken dep on libapt-pkg-libc6.4-6-3.53
  Considering apt 20 as a solution to debtags 3
  Removing debtags rather than change libapt-pkg-libc6.4-6-3.53
 Try to Re-Instate libk3b2
 Try to Re-Instate k3b
 Try to Re-Instate digikam
Investigating digikam
Package digikam has broken dep on libkexiv2-0
  Considering libkexiv2-0 -1 as a solution to digikam 0
  Added libkexiv2-0 to the remove list
  Fixing digikam via keep of libkexiv2-0
 Try to Re-Instate monodevelop
Investigating adept-common
Package adept-common has broken dep on debtags
  Considering debtags 3 as a solution to adept-common 4
  Added debtags to the remove list
  Fixing adept-common via keep of debtags
Investigating debtags
Package debtags has broken dep on libapt-pkg-libc6.4-6-3.53
  Considering apt 20 as a solution to debtags 4
  Removing debtags rather than change libapt-pkg-libc6.4-6-3.53
Investigating adept-common
Package adept-common has broken dep on debtags
  Considering debtags 20 as a solution to adept-common 4
  Removing adept-common rather than change debtags
Done
MarkUpgrade() called on a non-upgrable pkg: 'ubuntu-desktop'
MarkUpgrade() called on a non-upgrable pkg: 'kubuntu-desktop'
ERROR:root:Dist-upgrade failed: 'A essential package would have to be removed'
Installing libpango1.0-0 as dep of metacity
Installing libpango1.0-common as dep of libpango1.0-0
Installing libflac++5 as dep of libk3b2
Installing apt as dep of aptitude
Installing apt-utils as dep of python-apt
Installing libvte-common as dep of libvte9
Installing libcairomm-1.0-1 as dep of gnome-system-monitor
Installing libglibmm-2.4-1c2a as dep of gnome-system-monitor
Installing libgtkmm-2.4-1c2a as dep of gnome-system-monitor
Installing libgtop2-7 as dep of gnome-system-monitor
Installing libmono-cecil0.5-cil as dep of monodevelop
Starting
Starting 2
Investigating debtags
Package debtags has broken dep on libapt-pkg-libc6.4-6-3.53
  Considering apt 20 as a solution to debtags 3
  Removing debtags rather than change libapt-pkg-libc6.4-6-3.53
Investigating adept-manager
Package adept-manager has broken dep on libapt-pkg-libc6.4-6-3.53
  Considering apt 20 as a solution to adept-manager 2
  Removing adept-manager rather than change libapt-pkg-libc6.4-6-3.53
Investigating libk3b2
Package libk3b2 has broken dep on libflac++5
  Considering libflac++5 1 as a solution to libk3b2 2
  Holding Back libk3b2 rather than change libflac++5
Investigating adept-updater
Package adept-updater has broken dep on libapt-pkg-libc6.4-6-3.53
  Considering apt 20 as a solution to adept-updater 2
  Removing adept-updater rather than change libapt-pkg-libc6.4-6-3.53
Investigating adept
Package adept has broken dep on adept-manager
  Considering adept-manager 2 as a solution to adept 2
  Removing adept rather than change adept-manager
Investigating adept-installer
Package adept-installer has broken dep on libapt-pkg-libc6.4-6-3.53
  Considering apt 20 as a solution to adept-installer 1
  Removing adept-installer rather than change libapt-pkg-libc6.4-6-3.53
Investigating adept-batch
Package adept-batch has broken dep on libapt-pkg-libc6.4-6-3.53
  Considering apt 20 as a solution to adept-batch 1
  Removing adept-batch rather than change libapt-pkg-libc6.4-6-3.53
Investigating k3b
Package k3b has broken dep on libk3b2
  Considering libk3b2 2 as a solution to k3b 1
  Holding Back k3b rather than change libk3b2
Investigating language-selector-qt
Package language-selector-qt has broken dep on adept
  Considering adept 2 as a solution to language-selector-qt 1
  Removing language-selector-qt rather than change adept
Investigating adept-notifier
Package adept-notifier has broken dep on libapt-pkg-libc6.4-6-3.53
  Considering apt 20 as a solution to adept-notifier 1
  Removing adept-notifier rather than change libapt-pkg-libc6.4-6-3.53
Investigating kubuntu-desktop
Package kubuntu-desktop has broken dep on adept
  Considering adept 2 as a solution to kubuntu-desktop 0
  Removing kubuntu-desktop rather than change adept
Investigating libmono-cecil0.5-cil
Package libmono-cecil0.5-cil has broken dep on libmono-cecil0.4-cil
  Considering libmono-cecil0.4-cil 0 as a solution to libmono-cecil0.5-cil 0
  Holding Back libmono-cecil0.5-cil rather than change libmono-cecil0.4-cil
Investigating digikam
Package digikam has broken dep on libkexiv2-0
  Considering libkexiv2-0 -1 as a solution to digikam 0
  Added libkexiv2-0 to the remove list
Package digikam has broken dep on libexiv2-0.12
  Considering libexiv2-0.12 1 as a solution to digikam 0
  Holding Back digikam rather than change libexiv2-0.12
  Fixing digikam via remove of libkexiv2-0
Investigating monodevelop
Package monodevelop has broken dep on libmono-cecil0.5-cil
  Considering libmono-cecil0.5-cil 0 as a solution to monodevelop 0
  Holding Back monodevelop rather than change libmono-cecil0.5-cil
Investigating adept-common
Package adept-common has broken dep on debtags
  Considering debtags 3 as a solution to adept-common 4
  Added debtags to the remove list
  Fixing adept-common via keep of debtags
Investigating debtags
Package debtags has broken dep on libapt-pkg-libc6.4-6-3.53
  Considering apt 20 as a solution to debtags 3
  Removing debtags rather than change libapt-pkg-libc6.4-6-3.53
 Try to Re-Instate libk3b2
 Try to Re-Instate k3b
 Try to Re-Instate digikam
Investigating digikam
Package digikam has broken dep on libkexiv2-0
  Considering libkexiv2-0 -1 as a solution to digikam 0
  Added libkexiv2-0 to the remove list
  Fixing digikam via keep of libkexiv2-0
 Try to Re-Instate monodevelop
Investigating adept-common
Package adept-common has broken dep on debtags
  Considering debtags 3 as a solution to adept-common 4
  Added debtags to the remove list
  Fixing adept-common via keep of debtags
Investigating debtags
Package debtags has broken dep on libapt-pkg-libc6.4-6-3.53
  Considering apt 20 as a solution to debtags 4
  Removing debtags rather than change libapt-pkg-libc6.4-6-3.53
Investigating adept-common
Package adept-common has broken dep on debtags
  Considering debtags 20 as a solution to adept-common 4
  Removing adept-common rather than change debtags
Done
MarkUpgrade() called on a non-upgrable pkg: 'ubuntu-desktop'
MarkUpgrade() called on a non-upgrable pkg: 'kubuntu-desktop'

** Affects: xsp (Ubuntu)
     Importance: Undecided
         Status: New

-- 
Could not calculate the upgrade
https://bugs.launchpad.net/bugs/121280



More information about the Ubuntu-mono mailing list